summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/aspectj
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/aspectj')
-rw-r--r--dev-java/aspectj/Manifest2
-rw-r--r--dev-java/aspectj/aspectj-1.7.3-r1.ebuild47
-rw-r--r--dev-java/aspectj/aspectj-1.7.4.ebuild46
-rw-r--r--dev-java/aspectj/metadata.xml6
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-java/aspectj/Manifest b/dev-java/aspectj/Manifest
new file mode 100644
index 000000000000..dd9ed6b9c478
--- /dev/null
+++ b/dev-java/aspectj/Manifest
@@ -0,0 +1,2 @@
+DIST aspectj-1.7.3.jar 7565941 SHA256 02a3ddde559417483bddb40dc59442f441fa5ef0aafa54b26b862727c930d6cb SHA512 2297a11638c6519b50e1938341914c68c2841c7b7894081f3157ef3463fb29519d833d274e24b8da1203a7866b2e1296d67e0872dbaa2dd835b5520f5c0a7a71 WHIRLPOOL 39242d437a55da1bfb27703b7bf920c0836893b39aa4fe412c4fe96945835a5315f89cf26a478cf33dc8a99bedbe8dff5f59e03deb5fe3e337ec932d8c54ee3f
+DIST aspectj-1.7.4-src.jar 7570114 SHA256 75270a8f5f87e14c42a251441d62e31d05f85df2ed155e0036f36f10b6ae286d SHA512 643d457fba4d58114ee09a37007f5cf5fd40f7ff196ffc69d371d1986cbf6930567ddffd3f1af625139619a0be386e1d9c7e30d267bf53b4286e2179735299bf WHIRLPOOL 60688f65026eec16098ec077a84f0d7884287e0c7e465ad50796cf42c3724b5d6ee2d9d58e68baac66bb86b81a08581e0143bd60f5d74e04d40e04bb140bf219
diff --git a/dev-java/aspectj/aspectj-1.7.3-r1.ebuild b/dev-java/aspectj/aspectj-1.7.3-r1.ebuild
new file mode 100644
index 000000000000..629db6c1cee7
--- /dev/null
+++ b/dev-java/aspectj/aspectj-1.7.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A seamless aspect-oriented extension to the Java programming language"
+HOMEPAGE="http://eclipse.org/aspectj/"
+SRC_URI="http://www.eclipse.org/downloads/download.php?file=/tools/aspectj/aspectj-1.7.3-src.jar&r=1 -> ${P}.jar"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/asm:4
+ dev-java/commons-logging:0"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/zip
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}"
+
+JAVA_SRC_DIR="${S}/src"
+JAVA_GENTOO_CLASSPATH="commons-logging,asm-4"
+JAVA_ENCODING="iso8859-1"
+
+src_unpack() {
+ default
+ unzip "${S}/aspectjweaver1.7.3-src.jar" -d "${S}/src/" || die
+}
+
+java_prepare() {
+ default
+ # needs part of BEA JRockit to compile
+ rm "${S}"/src/org/aspectj/weaver/loadtime/JRockitAgent.java || die
+ # aspectj uses a renamed version of asm:4
+ find -name "*.java" -exec sed -i -e 's/import aj.org.objectweb.asm./import org.objectweb.asm./g' {} \; || die
+ mkdir -p "${S}"/target/classes/org/aspectj/weaver/ || die
+ cp -vr "${S}"/src/org/aspectj/weaver/*.properties "${S}"/target/classes/org/aspectj/weaver/ || die
+}
diff --git a/dev-java/aspectj/aspectj-1.7.4.ebuild b/dev-java/aspectj/aspectj-1.7.4.ebuild
new file mode 100644
index 000000000000..4c24f5610839
--- /dev/null
+++ b/dev-java/aspectj/aspectj-1.7.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A seamless aspect-oriented extension to the Java programming language"
+HOMEPAGE="http://eclipse.org/aspectj/"
+SRC_URI="http://www.eclipse.org/downloads/download.php?file=/tools/${PN}/${P}-src.jar&r=1 -> ${P}-src.jar"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND="dev-java/asm:4
+ dev-java/commons-logging:0"
+DEPEND="${CDEPEND}
+ app-arch/zip
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S=${WORKDIR}
+
+JAVA_SRC_DIR="${S}/src"
+JAVA_GENTOO_CLASSPATH="commons-logging,asm-4"
+JAVA_ENCODING="iso8859-1"
+
+src_unpack() {
+ default
+ unzip "${S}"/aspectjweaver${PV}-src.jar -d "${S}"/src/ || die
+}
+
+java_prepare() {
+ default
+
+ # needs part of BEA JRockit to compile
+ rm "${S}"/src/org/aspectj/weaver/loadtime/JRockitAgent.java || die
+ # aspectj uses a renamed version of asm:4
+ find -name "*.java" -exec sed -i -e 's/import aj.org.objectweb.asm./import org.objectweb.asm./g' {} \; || die
+ mkdir -p "${S}"/target/classes/org/aspectj/weaver/ || die
+ cp -vr "${S}"/src/org/aspectj/weaver/*.properties "${S}"/target/classes/org/aspectj/weaver/ || die
+}
diff --git a/dev-java/aspectj/metadata.xml b/dev-java/aspectj/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/aspectj/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+