summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/cldc-api/cldc-api-1.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/cldc-api/cldc-api-1.1-r1.ebuild')
-rw-r--r--dev-java/cldc-api/cldc-api-1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/cldc-api/cldc-api-1.1-r1.ebuild b/dev-java/cldc-api/cldc-api-1.1-r1.ebuild
new file mode 100644
index 000000000000..d4554dc95285
--- /dev/null
+++ b/dev-java/cldc-api/cldc-api-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java ME Connected Limited Device Configuration API"
+HOMEPAGE="http://java.sun.com/javame/reference/apis.jsp"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+# mkdir cldc-api-1.1 && cd cldc-api-1.1
+# you need a login on dev.java.net - use --username username if different from your local login
+# svn export https://phoneme.dev.java.net/svn/phoneme/components/cldc/trunk/src/javaapi/cldc1.1
+# svn export https://phoneme.dev.java.net/svn/phoneme/components/cldc/trunk/src/javaapi/share
+# cd ..
+# tar -cjf cldc-api-1.1.tar.bz2 cldc-api-1.1
+# move tarball to distdir, scp to d.g.o...
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+SLOT="1.1"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4"