summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-24 15:03:15 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-24 16:51:39 +0200
commit95f2bb96a1c2925c56ce8172315b824d8a9ba5ba (patch)
treee48a782e35737afe7838be54d36d2a9ab59244ab /dev-java/cofoja/cofoja-1.3.ebuild
parentapp-office/calcurse: clean up old. (diff)
downloadgentoo-95f2bb96a1c2925c56ce8172315b824d8a9ba5ba.tar.gz
gentoo-95f2bb96a1c2925c56ce8172315b824d8a9ba5ba.tar.bz2
gentoo-95f2bb96a1c2925c56ce8172315b824d8a9ba5ba.zip
dev-java/cofoja: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-java/cofoja/cofoja-1.3.ebuild')
-rw-r--r--dev-java/cofoja/cofoja-1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/cofoja/cofoja-1.3.ebuild b/dev-java/cofoja/cofoja-1.3.ebuild
new file mode 100644
index 000000000000..654d5541a289
--- /dev/null
+++ b/dev-java/cofoja/cofoja-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Contracts for Java"
+HOMEPAGE="https://github.com/nhatminhle/cofoja"
+SRC_URI="https://github.com/nhatminhle/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+CDEPEND="dev-java/asm:4"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="asm-4"
+JAVA_SRC_DIR="src/com/google/java/contract"
+
+src_prepare() {
+ default
+
+ # Relies on a bunch of classes in jsr308,
+ # spec we don't have packaged in Gentoo.. yet.
+ rm -v src/com/google/java/contract/core/apt/JavacUtils.java || die
+}