summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-attributes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-attributes')
-rw-r--r--dev-java/commons-attributes/Manifest1
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild52
-rw-r--r--dev-java/commons-attributes/metadata.xml5
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/commons-attributes/Manifest b/dev-java/commons-attributes/Manifest
new file mode 100644
index 000000000000..f612f144d4ae
--- /dev/null
+++ b/dev-java/commons-attributes/Manifest
@@ -0,0 +1 @@
+DIST commons-attributes-2.2-src.tar.gz 98307 SHA256 f24acddd1b82db16052672c255bd57add05107bbb1220264aec6ba10091e7713 SHA512 6030af498f085c56b313f473d3f44fc063608b9e0d7442e2f7fd0ee73c320b84cc334dd75038ab3aaac4b72a54cf12f3e3bddfb7faf3610f0f080c389f370e07 WHIRLPOOL b5a03da8126f8df02977a4318dd7cd6e1ebdb0b15f6932e344abb4b44dc1ee8e98214f3ff01fc0eeaf6b4ff6f47eeb67b4f7b6bc692407283c10f510947b4faf
diff --git a/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild b/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild
new file mode 100644
index 000000000000..0860a7b64641
--- /dev/null
+++ b/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Attributes enables Java programmers to use C#/.Net-style attributes in their code"
+HOMEPAGE="http://commons.apache.org/attributes/"
+SRC_URI="mirror://apache/commons/attributes/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEP="dev-java/ant-core:0
+ dev-java/gjdoc:0
+ dev-java/qdox:1.6
+ dev-java/xjavadoc:0"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="ant-core,gjdoc,qdox-1.6"
+
+src_compile() {
+ java-pkg-2_src_compile
+
+ # The generated build.xml is faulty.
+ jar uf target/${PN}-compiler-${PV}.jar -C compiler/src/java \
+ org/apache/commons/attributes/anttasks.properties || die
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-compiler-${PV}.jar ${PN}-compiler.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE.txt
+ dohtml README.html
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc api/src/java/org compiler/src/java/org
+}
diff --git a/dev-java/commons-attributes/metadata.xml b/dev-java/commons-attributes/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-attributes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>