summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-betwixt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-betwixt')
-rw-r--r--dev-java/commons-betwixt/Manifest1
-rw-r--r--dev-java/commons-betwixt/commons-betwixt-0.8.ebuild55
-rw-r--r--dev-java/commons-betwixt/files/commons-betwixt-0.6-noget.patch27
-rw-r--r--dev-java/commons-betwixt/files/commons-betwixt-0.7-notests.patch25
-rw-r--r--dev-java/commons-betwixt/files/commons-betwixt-0.8-test-dtd.patch16
-rw-r--r--dev-java/commons-betwixt/metadata.xml18
6 files changed, 142 insertions, 0 deletions
diff --git a/dev-java/commons-betwixt/Manifest b/dev-java/commons-betwixt/Manifest
new file mode 100644
index 000000000000..708956527a6f
--- /dev/null
+++ b/dev-java/commons-betwixt/Manifest
@@ -0,0 +1 @@
+DIST commons-betwixt-0.8-src.tar.gz 359821 SHA256 86db2d772c5ffe134a96a6d79410896ec7ec75ed6d8824b39a5be6d2df384af2 SHA512 9d82807b13b7c0dfedf2def35c80bd7467cafbec1a3a5a4e188d56ed4940c43238c12fd7f334ce0a3ff990c60af4cf94ba42adbcb7bbb21a2775ed7762fb0668 WHIRLPOOL 9641342f7f2317520465fa0b7e8f65d26023f3054d458b755d31855690f6e776895de5dba2e7bf450e89bba4956718bd5ce7de9b5efe138abd877d1ff68ee6e0
diff --git a/dev-java/commons-betwixt/commons-betwixt-0.8.ebuild b/dev-java/commons-betwixt/commons-betwixt-0.8.ebuild
new file mode 100644
index 000000000000..dc349c8e6b73
--- /dev/null
+++ b/dev-java/commons-betwixt/commons-betwixt-0.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="Introspective Bean to XML mapper"
+
+LICENSE="Apache-2.0"
+SLOT="0.7"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/commons-collections:0
+ >=dev-java/commons-logging-1.0.2:0
+ dev-java/commons-beanutils:1.7
+ >=dev-java/commons-digester-1.6:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}
+ test? (
+ dev-java/ant-junit:0
+ >=dev-java/xerces-2.7:2
+ )"
+
+S="${WORKDIR}/${P}-src/"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+EANT_GENTOO_CLASSPATH="commons-beanutils-1.7,commons-collections,commons-digester,commons-logging"
+EANT_BUILD_TARGET="init jar"
+
+java_prepare() {
+ epatch "${FILESDIR}/${PN}-0.8-test-dtd.patch"
+}
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},xerces-2"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}*.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-betwixt/files/commons-betwixt-0.6-noget.patch b/dev-java/commons-betwixt/files/commons-betwixt-0.6-noget.patch
new file mode 100644
index 000000000000..18ed111f1614
--- /dev/null
+++ b/dev-java/commons-betwixt/files/commons-betwixt-0.6-noget.patch
@@ -0,0 +1,27 @@
+--- build.xml.orig 2005-03-29 00:13:46.324523008 +0200
++++ build.xml 2005-03-29 00:14:15.329113640 +0200
+@@ -45,7 +45,7 @@
+ </equals>
+ </condition>
+ </target>
+- <target name="compile" description="o Compile the code" depends="get-deps">
++ <target name="compile" description="o Compile the code">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+@@ -67,7 +67,7 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
+@@ -187,4 +187,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/commons-betwixt/files/commons-betwixt-0.7-notests.patch b/dev-java/commons-betwixt/files/commons-betwixt-0.7-notests.patch
new file mode 100644
index 000000000000..b0581b23f40a
--- /dev/null
+++ b/dev-java/commons-betwixt/files/commons-betwixt-0.7-notests.patch
@@ -0,0 +1,25 @@
+diff -ru commons-betwixt-0.7-src/build.xml commons-betwixt-0.7-src-patched/build.xml
+--- commons-betwixt-0.7-src/build.xml 2005-07-25 17:24:03.000000000 -0400
++++ commons-betwixt-0.7-src-patched/build.xml 2005-12-14 23:53:30.000000000 -0500
+@@ -86,11 +86,11 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
++ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test" unless="notest">
+ <fail message="There were test failures.">
+ </fail>
+ </target>
+- <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
++ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests" unless="notest">
+ <mkdir dir="${testreportdir}">
+ </mkdir>
+ <junit dir="./" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+@@ -185,4 +185,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
+Only in commons-betwixt-0.7-src-patched: target
diff --git a/dev-java/commons-betwixt/files/commons-betwixt-0.8-test-dtd.patch b/dev-java/commons-betwixt/files/commons-betwixt-0.8-test-dtd.patch
new file mode 100644
index 000000000000..221874bd4995
--- /dev/null
+++ b/dev-java/commons-betwixt/files/commons-betwixt-0.8-test-dtd.patch
@@ -0,0 +1,16 @@
+--- commons-betwixt-0.8-src/src/test/org/apache/commons/betwixt/rss-example.xml 2006-12-21 23:14:19.000000000 +0100
++++ commons-betwixt-0.8-src/src/test/org/apache/commons/betwixt/rss-example.xml.new 2010-01-11 21:48:59.000000000 +0100
+@@ -15,10 +15,12 @@
+ See the License for the specific language governing permissions and
+ limitations under the License.
+ -->
++
++<!--
+ <!DOCTYPE rss PUBLIC
+ "-//Netscape Communications//DTD RSS 0.91//EN"
+ "http://my.netscape.com/publish/formats/rss-0.91.dtd">
+-
++-->
+ <rss version="0.91">
+
+ <channel>
diff --git a/dev-java/commons-betwixt/metadata.xml b/dev-java/commons-betwixt/metadata.xml
new file mode 100644
index 000000000000..392662d241d0
--- /dev/null
+++ b/dev-java/commons-betwixt/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+ The Betwixt library provides an XML introspection mechanism for mapping
+ beans to XML in a flexible way. It is implemented using an XMLIntrospector
+ and XMLBeanInfo classes which are similar to the standard Introspector and
+ BeanInfo from the Java Beans specification.
+
+ Betwixt provides a way of turning beans into XML as well as automatically
+ generating digester rules in a way that can be customized on a per type
+ manner in the same way that the BeanInfo mechanism can be used to customize
+ the default introspection on a java object.
+</longdescription>
+
+</pkgmetadata>