summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild')
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild b/dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild
new file mode 100644
index 000000000000..53634338ea40
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-3.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="The Jakarta Commons HttpClient library"
+HOMEPAGE="http://hc.apache.org/"
+SRC_URI="mirror://apache/httpcomponents/${PN}/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+# doesn't work with IBM JDK, bug #176133
+RESTRICT="test"
+
+CDEPEND="dev-java/commons-logging:0
+ dev-java/commons-codec:0"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )
+ ${CDEPEND}"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-logging,commons-codec"
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="doc"
+
+java_prepare() {
+ # patch against CVE-2012-{5783,6153}. See bug 442292.
+ epatch "${FILESDIR}"/"${P}-SSLProtocolSocketFactory.java.patch"
+
+ # generated docs go into docs/api
+ rm -rf docs/apidocs
+
+ # remove javadoc task from compile task
+ sed -i -e 's/depends="compile,doc"/depends="compile"/' build.xml || die
+ sed -i -e '/link/ d' build.xml || die
+
+ mkdir lib && cd lib
+ java-pkg_filter-compiler jikes
+}
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit"
+EANT_TEST_TARGET="test"
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ # contains both html docs and javadoc in correct subdir
+ if use doc ; then
+ java-pkg_dojavadoc dist/docs/api
+ java-pkg_dohtml -r dist/docs/*
+ fi
+ use source && java-pkg_dosrc src/java/*
+ use examples && java-pkg_doexamples src/examples
+}