summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-16 14:49:04 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-16 15:03:53 +0100
commitb128d2e87ed77bc98231a053b2eb2f4b1ffaad03 (patch)
tree18ef47c44e220921ec74b76e344e5d69fdb1e91e /dev-java/cssparser/cssparser-0.9.22.ebuild
parentnet-libs/nodejs: Bump (diff)
downloadgentoo-b128d2e87ed77bc98231a053b2eb2f4b1ffaad03.tar.gz
gentoo-b128d2e87ed77bc98231a053b2eb2f4b1ffaad03.tar.bz2
gentoo-b128d2e87ed77bc98231a053b2eb2f4b1ffaad03.zip
dev-java/cssparser: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-java/cssparser/cssparser-0.9.22.ebuild')
-rw-r--r--dev-java/cssparser/cssparser-0.9.22.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/cssparser/cssparser-0.9.22.ebuild b/dev-java/cssparser/cssparser-0.9.22.ebuild
new file mode 100644
index 000000000000..1c5d6a03f8b2
--- /dev/null
+++ b/dev-java/cssparser/cssparser-0.9.22.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="API for parsing CSS 2 in Java"
+HOMEPAGE="http://cssparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.jar -> ${P}.jar"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/sac:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_GENTOO_CLASSPATH="sac"