summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/dbus-java/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/dbus-java/files')
-rw-r--r--dev-java/dbus-java/files/TestSignalInterface2-2.5.1.java45
-rw-r--r--dev-java/dbus-java/files/dbus-java-2.5.1-jarfixes.patch25
-rw-r--r--dev-java/dbus-java/files/dbus-java-2.6-disconnectfix.patch21
-rw-r--r--dev-java/dbus-java/files/dbus-java-htlatex.patch11
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-java/dbus-java/files/TestSignalInterface2-2.5.1.java b/dev-java/dbus-java/files/TestSignalInterface2-2.5.1.java
new file mode 100644
index 000000000000..d5c9ac521c4e
--- /dev/null
+++ b/dev-java/dbus-java/files/TestSignalInterface2-2.5.1.java
@@ -0,0 +1,45 @@
+/*
+ D-Bus Java Implementation
+ Copyright (c) 2005-2006 Matthew Johnson
+
+ This program is free software; you can redistribute it and/or modify it
+ under the terms of either the GNU Lesser General Public License Version 2 or the
+ Academic Free Licence Version 2.1.
+
+ Full licence texts are included in the COPYING file with this program.
+*/
+package org.freedesktop.dbus.test;
+
+import org.freedesktop.DBus.Description;
+import org.freedesktop.dbus.DBusInterface;
+import org.freedesktop.dbus.DBusInterfaceName;
+import org.freedesktop.dbus.DBusMemberName;
+import org.freedesktop.dbus.DBusSignal;
+import org.freedesktop.dbus.UInt32;
+import org.freedesktop.dbus.exceptions.DBusException;
+
+import java.util.List;
+
+/**
+ * A sample signal with two parameters
+ */
+@Description("Test interface containing signals")
+@DBusInterfaceName("some.other.interface.Name")
+public interface TestSignalInterface2 extends DBusInterface
+{
+ @Description("Test basic signal")
+ public static class TestRenamedSignal extends DBusSignal
+ {
+ public final String value;
+ public final UInt32 number;
+ /**
+ * Create a signal.
+ */
+ public TestRenamedSignal(String path, String value, UInt32 number) throws DBusException
+ {
+ super(path, value, number);
+ this.value = value;
+ this.number = number;
+ }
+ }
+}
diff --git a/dev-java/dbus-java/files/dbus-java-2.5.1-jarfixes.patch b/dev-java/dbus-java/files/dbus-java-2.5.1-jarfixes.patch
new file mode 100644
index 000000000000..cd49726b6403
--- /dev/null
+++ b/dev-java/dbus-java/files/dbus-java-2.5.1-jarfixes.patch
@@ -0,0 +1,25 @@
+diff -Nur dbus-java-2.5.1/Makefile dbus-java-2.5.1_patched/Makefile
+--- dbus-java-2.5.1/Makefile 2008-07-21 13:44:10.000000000 +0300
++++ dbus-java-2.5.1_patched/Makefile 2008-11-28 07:10:30.000000000 +0200
+@@ -87,17 +87,13 @@
+ sed -n '/_(/s/.*_("\([^"]*\)").*/\1/p' $^ | sort -u | sed 's/\(.*\)/msgid "\1"\nmsgstr "\1"/' >> $@
+
+ libdbus-java-$(VERSION).jar: .classes
+- echo "Class-Path: ${JAVAUNIXJARDIR}/unix.jar ${JAVAUNIXJARDIR}/hexdump.jar ${JAVAUNIXJARDIR}/debug-$(DEBUG).jar" > Manifest
+- (cd classes; $(JAR) -cfm ../$@ ../Manifest org/freedesktop/dbus/*.class org/freedesktop/*.class org/freedesktop/dbus/types/*.class org/freedesktop/dbus/exceptions/*.class *localized*class)
++ (cd classes; $(JAR) -cf ../$@ org/freedesktop/dbus/*.class org/freedesktop/*.class org/freedesktop/dbus/types/*.class org/freedesktop/dbus/exceptions/*.class *localized*class)
+ dbus-java-test-$(VERSION).jar: .testclasses
+- echo "Class-Path: ${JARPREFIX}/libdbus-java-$(VERSION).jar" > Manifest
+- (cd classes; $(JAR) -cfm ../$@ ../Manifest org/freedesktop/dbus/test/*.class)
++ (cd classes; $(JAR) -cf ../$@ org/freedesktop/dbus/test/*.class)
+ dbus-java-viewer-$(VERSION).jar: .viewerclasses
+- echo "Class-Path: ${JARPREFIX}/libdbus-java-$(VERSION).jar" > Manifest
+- (cd classes; $(JAR) -cfm ../$@ ../Manifest org/freedesktop/dbus/viewer/*.class)
++ (cd classes; $(JAR) -cf ../$@ org/freedesktop/dbus/viewer/*.class)
+ dbus-java-bin-$(VERSION).jar: .binclasses
+- echo "Class-Path: ${JARPREFIX}/libdbus-java-$(VERSION).jar" > Manifest
+- (cd classes; $(JAR) -cfm ../$@ ../Manifest org/freedesktop/dbus/bin/*.class)
++ (cd classes; $(JAR) -cf ../$@ org/freedesktop/dbus/bin/*.class)
+ dbus.jar: libdbus-java-$(VERSION).jar
+ ln -sf $< $@
+ dbus-bin.jar: dbus-java-bin-$(VERSION).jar
diff --git a/dev-java/dbus-java/files/dbus-java-2.6-disconnectfix.patch b/dev-java/dbus-java/files/dbus-java-2.6-disconnectfix.patch
new file mode 100644
index 000000000000..73825676ddb7
--- /dev/null
+++ b/dev-java/dbus-java/files/dbus-java-2.6-disconnectfix.patch
@@ -0,0 +1,21 @@
+diff --git a/org/freedesktop/dbus/Error.java b/org/freedesktop/dbus/Error.java
+index 16e1126..9db1e07 100644
+--- a/org/freedesktop/dbus/Error.java
++++ b/org/freedesktop/dbus/Error.java
+@@ -17,6 +17,7 @@ import java.util.Vector;
+ import org.freedesktop.dbus.exceptions.DBusException;
+ import org.freedesktop.dbus.exceptions.DBusExecutionException;
+ import org.freedesktop.dbus.exceptions.MessageFormatException;
++import org.freedesktop.dbus.exceptions.NotConnected;
+
+ import cx.ath.matthew.debug.Debug;
+
+@@ -79,6 +80,7 @@ public class Error extends Message
+ @SuppressWarnings("unchecked")
+ private static Class<? extends DBusExecutionException> createExceptionClass(String name)
+ {
++ if (name == "org.freedesktop.DBus.Local.Disconnected") return NotConnected.class;
+ Class<? extends DBusExecutionException> c = null;
+ do {
+ try {
+
diff --git a/dev-java/dbus-java/files/dbus-java-htlatex.patch b/dev-java/dbus-java/files/dbus-java-htlatex.patch
new file mode 100644
index 000000000000..ebb278ad169b
--- /dev/null
+++ b/dev-java/dbus-java/files/dbus-java-htlatex.patch
@@ -0,0 +1,11 @@
+--- Makefile~ 2009-11-01 14:53:27.000000000 +0100
++++ Makefile 2010-05-08 16:26:10.000000000 +0200
+@@ -131,7 +131,7 @@
+ (cd doc; pdflatex ../dbus-java.tex)
+ doc/dbus-java/index.html: dbus-java.tex .doc
+ mkdir -p doc/dbus-java/
+- (cd doc/dbus-java; TEX4HTENV=/etc/tex4ht/tex4ht.env htlatex ../../dbus-java.tex "xhtml,2" "" "-cvalidate")
++ (cd doc/dbus-java; TEX4HTENV=/etc/tex4ht/tex4ht.env mk4ht htlatex ../../dbus-java.tex "xhtml,2" "" "-cvalidate")
+ rm -f doc/dbus-java/*{4ct,4tc,aux,dvi,idv,lg,log,tmp,xref}
+ cp doc/dbus-java/dbus-java.html doc/dbus-java/index.html
+ doc/api/index.html: $(SRCDIR)/*.java $(SRCDIR)/dbus/*.java .doc