summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2015-12-04 18:52:20 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2015-12-04 18:56:24 +0100
commitfeafc7e321c93ffdd4f4b7fdfeb3f6a54fdef306 (patch)
tree684c0c6277c1a81ce1c803e5cac503e1a05b59f3 /dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild
parentprofiles/package.mask: Unmask pypy-4.0.1 (diff)
downloadgentoo-feafc7e321c93ffdd4f4b7fdfeb3f6a54fdef306.tar.gz
gentoo-feafc7e321c93ffdd4f4b7fdfeb3f6a54fdef306.tar.bz2
gentoo-feafc7e321c93ffdd4f4b7fdfeb3f6a54fdef306.zip
dev-java/eclipse-ecj: version bump - new slot 4.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild')
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild
new file mode 100644
index 000000000000..a690ae14a28c
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-4.5.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="ecj"
+DMF="R-${PV}-201509040015"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/${MY_PN}src-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.5"
+IUSE="+ant"
+
+COMMON_DEP="
+ app-eselect/eselect-java"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.7"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+PDEPEND="
+ ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+JAVA_JAR_FILENAME="${MY_PN}.jar"
+
+S="${WORKDIR}"
+
+# See https://bugs.eclipse.org/bugs/show_bug.cgi?id=479134 for details
+java_prepare() {
+ # These have their own package.
+ rm org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -r org/eclipse/jdt/internal/antadapter || die
+
+ # JavaCore is not distributed in the jar
+ sed -i -e '/import org.eclipse.jdt.core.JavaCore;/d' \
+ -e 's|JavaCore.getOptions()||g' \
+ org/eclipse/jdt/internal/compiler/batch/ClasspathDirectory.java
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org META-INF -type f ! -name "*.java" | xargs jar uvf "${JAVA_JAR_FILENAME}" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}