summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-03-23 00:58:10 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-23 00:59:09 +0100
commitda4b042a67a7f11c292300c5939ad8d30423cabb (patch)
tree3a681968242baebea816ea5b2cb82d27079db4b1 /dev-java/eclipsito
parentx11-base/xorg-server: IUSE no longer defaults to elogind, suid enabled. (diff)
downloadgentoo-da4b042a67a7f11c292300c5939ad8d30423cabb.tar.gz
gentoo-da4b042a67a7f11c292300c5939ad8d30423cabb.tar.bz2
gentoo-da4b042a67a7f11c292300c5939ad8d30423cabb.zip
dev-java/eclipsito: update ebuild.
- EAPI 6 bump. - Update HOMEPAGE. - Update SRC_URI. Closes: https://bugs.gentoo.org/680376 Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-java/eclipsito')
-rw-r--r--dev-java/eclipsito/Manifest1
-rw-r--r--dev-java/eclipsito/eclipsito-20180510.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/eclipsito/Manifest b/dev-java/eclipsito/Manifest
index b0d1b1e2f8c6..e083d5b40a15 100644
--- a/dev-java/eclipsito/Manifest
+++ b/dev-java/eclipsito/Manifest
@@ -1 +1,2 @@
DIST eclipsito-0_pre20130713.tar.xz 162972 BLAKE2B 193a3b2c4bee39bfb87c49eb8b077804d26ef1f84a1dc2c3546d235ab6fa8f86340c943b1a5ce1044dcd5681751d856a044d75866717a0c976e82c86ae8a1ab1 SHA512 b238692950bc93059fb16df8e6301669583185976ae4f12519d1917a13fea2b53c5b3462f2da61d63025019eee10037a3a96b2ac742545d61b80f2ab7964d41b
+DIST eclipsito-20180510.tar.gz 66661 BLAKE2B 0cd1879314eaf4acfcb26cd37f27c50208263cc584d15cb19cfee4d75b29e925d7840be6f39fdf2b6aa05d26f1497284d2d772f9a42ea81398aeec9b1ebad029 SHA512 420cc4ed44fc80065452b39350625f5621175e0bd2aae1ba38a409134bd92af23b492c01f826234431fec68e09eecdf47d61a06f02338e5998c2c5cad44fd142
diff --git a/dev-java/eclipsito/eclipsito-20180510.ebuild b/dev-java/eclipsito/eclipsito-20180510.ebuild
new file mode 100644
index 000000000000..2c5cf97ca604
--- /dev/null
+++ b/dev-java/eclipsito/eclipsito-20180510.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+COMMIT="0eb2fbb739898f55265027c2796f77fbee9f4ab2"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="A small subset of Eclipse core libraries for modular applications"
+HOMEPAGE="https://github.com/bardsoftware/eclipsito"
+SRC_URI="https://github.com/bardsoftware/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=">=virtual/jdk-1.8"
+
+S="${WORKDIR}/${P}/org.bardsoftware.${PN}"
+
+src_prepare() {
+ default
+ rm -r src/org/bardsoftware/test || die
+}