summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-27 23:20:43 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-27 23:22:14 +0100
commit0210dc884496a12afa3ac17e2a385a9378474695 (patch)
treeded61a96bede6e6a958f5c1cb1c555883ed38875 /dev-java/edtftpj/edtftpj-2.4.0.ebuild
parentapp-admin/puppetserver: bup for bug 581372 (diff)
downloadgentoo-0210dc884496a12afa3ac17e2a385a9378474695.tar.gz
gentoo-0210dc884496a12afa3ac17e2a385a9378474695.tar.bz2
gentoo-0210dc884496a12afa3ac17e2a385a9378474695.zip
dev-java/edtftpj: Version bump to 2.4.0, fixes bug #581244
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/edtftpj/edtftpj-2.4.0.ebuild')
-rw-r--r--dev-java/edtftpj/edtftpj-2.4.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/edtftpj/edtftpj-2.4.0.ebuild b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
new file mode 100644
index 000000000000..ecfe0df6f5de
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="http://enterprisedt.com/products/edtftpnet"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.7"
+
+EANT_DOC_TARGET="javadocs"
+EANT_BUILD_XML="src/build.xml"
+
+java_prepare() {
+ java-pkg_clean
+
+ # Tests are geared for Windows and sit in the main sources.
+ rm -rv src/com/enterprisedt/net/ftp/test || die
+
+ # Delete Windows .bat files.
+ find -name "*.bat" -delete || die
+
+ # Adjust doc URLs to match our layout.
+ find examples -name "*.html" -exec sed -i 's:/doc/manual/:/manual/:g' {} + || die
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ use doc && java-pkg_dojavadoc build/doc/api
+ use source && java-pkg_dosrc src/*
+
+ docinto html
+ use doc && dodoc -r doc/manual
+ use examples && dodoc -r examples
+}