summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-28 14:16:42 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-28 14:19:32 -0500
commit230d463c955bd3bbdee3f7ede4cf365cb9dd6ff3 (patch)
tree92a73fd6c912553a0b5f8774c2aee044d8f24531 /dev-java/ezmorph/ezmorph-1.0.6.ebuild
parentdev-util/coccinelle: Remove old, #586930 (diff)
downloadgentoo-230d463c955bd3bbdee3f7ede4cf365cb9dd6ff3.tar.gz
gentoo-230d463c955bd3bbdee3f7ede4cf365cb9dd6ff3.tar.bz2
gentoo-230d463c955bd3bbdee3f7ede4cf365cb9dd6ff3.zip
dev-java/ezmorph: new ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/ezmorph/ezmorph-1.0.6.ebuild')
-rw-r--r--dev-java/ezmorph/ezmorph-1.0.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/ezmorph/ezmorph-1.0.6.ebuild b/dev-java/ezmorph/ezmorph-1.0.6.ebuild
new file mode 100644
index 000000000000..4c6abb0b9e7a
--- /dev/null
+++ b/dev-java/ezmorph/ezmorph-1.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A simple Java library for transforming an Object to another Object"
+HOMEPAGE="http://ezmorph.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEP="dev-java/commons-lang:2.1
+ dev-java/commons-beanutils:1.7
+ dev-java/commons-logging:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+JAVA_GENTOO_CLASSPATH="
+ commons-lang-2.1
+ commons-beanutils-1.7
+ commons-logging"
+
+RESTRICT=test #564158
+
+java_prepare() {
+ # Don't build tests all the time
+ if ! use test ; then
+ rm -r net/sf/ezmorph/test || die
+ fi
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ use doc && java-pkg_dojavadoc target/api
+ use source && java-pkg_dosrc net
+}