summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-07 07:41:33 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-07 07:42:03 +0000
commitc930df63a65a4d1cf18fddab86b456b8c00cdf0f (patch)
tree78c62c661243dc65b17c49c321748fc5fbccb234 /dev-java/fastutil/fastutil-7.0.10.ebuild
parentapp-admin/passwordsafe: Fix metadata.xml file. (diff)
downloadgentoo-c930df63a65a4d1cf18fddab86b456b8c00cdf0f.tar.gz
gentoo-c930df63a65a4d1cf18fddab86b456b8c00cdf0f.tar.bz2
gentoo-c930df63a65a4d1cf18fddab86b456b8c00cdf0f.zip
dev-java/fastutil: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/fastutil/fastutil-7.0.10.ebuild')
-rw-r--r--dev-java/fastutil/fastutil-7.0.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/fastutil/fastutil-7.0.10.ebuild b/dev-java/fastutil/fastutil-7.0.10.ebuild
new file mode 100644
index 000000000000..e20bd2449a7d
--- /dev/null
+++ b/dev-java/fastutil/fastutil-7.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides faster type-specific maps, sets and lists with a small memory footprint"
+HOMEPAGE="https://github.com/vigna/fastutil"
+SRC_URI="https://github.com/vigna/fastutil/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+src_compile() {
+ emake sources
+
+ # bug 162650 and #175578
+ java-pkg_init-compiler_
+
+ [[ ${GENTOO_COMPILER} != "javac" ]] && export ANT_OPTS="-Xmx512m"
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_newjar "${P}.jar"
+
+ dodoc CHANGES README.md
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/it
+}