summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/felix-bundlerepository
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/felix-bundlerepository')
-rw-r--r--dev-java/felix-bundlerepository/Manifest1
-rw-r--r--dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild51
-rw-r--r--dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml195
-rw-r--r--dev-java/felix-bundlerepository/metadata.xml5
4 files changed, 252 insertions, 0 deletions
diff --git a/dev-java/felix-bundlerepository/Manifest b/dev-java/felix-bundlerepository/Manifest
new file mode 100644
index 000000000000..df5b3358e2e8
--- /dev/null
+++ b/dev-java/felix-bundlerepository/Manifest
@@ -0,0 +1 @@
+DIST org.apache.felix.bundlerepository-1.6.6-source-release.tar.gz 163337 SHA256 cdf1a16e2cd1779f403d58225666c6eee6e4018e9775d195f227b77ae9a88da4 SHA512 a457dacf0b15a54aad9290a3620b4dee503bb7d06eac1e2e9b151613caafdd53b104e8266b10321d04d0fb400df6f9f2131ed03f48bf166205903aa69f260b46 WHIRLPOOL 9d0fea404c7f34b3ed6b5f4edfaf610a01915a2d069b4324f78537233011fc1ef57251ffda5c80b0400cb3283f1c6f863df049bcb8643646158178b2ede337ec
diff --git a/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild b/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild
new file mode 100644
index 000000000000..1dbff6813c73
--- /dev/null
+++ b/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="Felix Bundle Repository"
+HOMEPAGE="http://felix.apache.org/"
+LICENSE="Apache-2.0"
+
+MY_PN="org.apache.felix.bundlerepository"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://apache/felix/${MY_P}-source-release.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="
+ dev-java/kxml:2
+ dev-java/xpp3:0
+ dev-java/felix-shell:0
+ dev-java/felix-utils:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-obr:0
+"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ sed -i 's/bestVersion.compareTo(v)/bestVersion.compareTo((Version) v)/g' \
+ src/main/java/org/apache/felix/bundlerepository/impl/ResolverImpl.java \
+ || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="osgi-core-api,felix-utils,felix-shell,xpp3,kxml-2,osgi-obr"
+
+src_install() {
+ mv target/{${MY_P},${PN}}.jar || die
+
+ java-osgi_dojar target/${PN}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+}
diff --git a/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml b/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml
new file mode 100644
index 000000000000..0c7398178af1
--- /dev/null
+++ b/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml
@@ -0,0 +1,195 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project name="org.apache.felix.bundlerepository-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+ <property name="maven.build.finalName" value="org.apache.felix.bundlerepository-1.6.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.utils/1.1.0/org.apache.felix.utils-1.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.service.obr/1.0.2/org.osgi.service.obr-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.core/1.0.1/org.osgi.core-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.shell/1.4.1/org.apache.felix.shell-1.4.1.jar"/>
+ <pathelement location="${maven.repo.local}/net/sf/kxml/kxml2/2.3.0/kxml2-2.3.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/woodstox-core-asl/4.0.7/woodstox-core-asl-4.0.7.jar"/>
+ <pathelement location="${maven.repo.local}/stax/stax-api/1.0.1/stax-api-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/stax2-api/3.0.1/stax2-api-3.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.utils/1.1.0/org.apache.felix.utils-1.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.service.obr/1.0.2/org.osgi.service.obr-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.core/1.0.1/org.osgi.core-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.shell/1.4.1/org.apache.felix.shell-1.4.1.jar"/>
+ <pathelement location="${maven.repo.local}/net/sf/kxml/kxml2/2.3.0/kxml2-2.3.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/woodstox-core-asl/4.0.7/woodstox-core-asl-4.0.7.jar"/>
+ <pathelement location="${maven.repo.local}/stax/stax-api/1.0.1/stax-api-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/stax2-api/3.0.1/stax2-api-3.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"/>
+ </path>
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="changelog.txt"/>
+ </fileset>
+ </copy>
+ </target>
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/felix-bundlerepository/metadata.xml b/dev-java/felix-bundlerepository/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/felix-bundlerepository/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>