summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-01-26 15:39:57 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-04-10 17:12:51 +0200
commit9b5bcd2ebb29a13c64bd780895d8bbeb3486f56a (patch)
tree72d83eee97370c2195406fd7bd516667da89fb32 /dev-java/findbugs-annotations
parentdev-util/poke: update HOMEPAGE (diff)
downloadgentoo-9b5bcd2ebb29a13c64bd780895d8bbeb3486f56a.tar.gz
gentoo-9b5bcd2ebb29a13c64bd780895d8bbeb3486f56a.tar.bz2
gentoo-9b5bcd2ebb29a13c64bd780895d8bbeb3486f56a.zip
dev-java/findbugs-annotations: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/findbugs-annotations')
-rw-r--r--dev-java/findbugs-annotations/Manifest1
-rw-r--r--dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild41
-rw-r--r--dev-java/findbugs-annotations/metadata.xml7
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/findbugs-annotations/Manifest b/dev-java/findbugs-annotations/Manifest
new file mode 100644
index 000000000000..d218d89a086e
--- /dev/null
+++ b/dev-java/findbugs-annotations/Manifest
@@ -0,0 +1 @@
+DIST findbugs-annotations-3.0.1-sources.jar 25170 BLAKE2B aebd9acccae5d4fe209aa9393fb35868a67096889375eab5817eeb6b6cabe950e1a3479826c921254fa1faeaaa8231095b5ef88dc2f83fa3b6ca2a76a1572b42 SHA512 bf77991bcbad1dd3e072c65df36d7714cf2f2967a01ed9e8435b6b40c925d905fc879c83303a227cffa5c3db4c960c9c6813ebb520f5d1c0f178f27710075d43
diff --git a/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
new file mode 100644
index 000000000000..22b9af5b27f8
--- /dev/null
+++ b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom findbugs-annotations-3.0.1.pom --download-uri https://repo1.maven.org/maven2/com/google/code/findbugs/findbugs-annotations/3.0.1/findbugs-annotations-3.0.1-sources.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild findbugs-annotations-3.0.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.google.code.findbugs:findbugs-annotations:3.0.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Annotation defined by the FindBugs tool"
+HOMEPAGE="http://findbugs.sourceforge.net/"
+SRC_URI="https://repo1.maven.org/maven2/com/google/code/findbugs/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: ${P}.pom
+# com.google.code.findbugs:jsr305:3.0.1 -> >=dev-java/jsr305-3.0.2:0
+
+CP_DEPEND="
+ >=dev-java/jsr305-3.0.2:0
+"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
diff --git a/dev-java/findbugs-annotations/metadata.xml b/dev-java/findbugs-annotations/metadata.xml
new file mode 100644
index 000000000000..75321cfb5598
--- /dev/null
+++ b/dev-java/findbugs-annotations/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>