summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-05-25 13:44:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-05-25 22:58:30 +0100
commit21ecc35f5ba74e4ea0f569aa887b5761522e62df (patch)
tree282d8ef939b206eea0868b96dcdd9e6db0a55c97 /dev-java/freehep-io/freehep-io-2.2.2.ebuild
parentkde-base/kdelibs: Remove 4.14.8 (diff)
downloadgentoo-21ecc35f5ba74e4ea0f569aa887b5761522e62df.tar.gz
gentoo-21ecc35f5ba74e4ea0f569aa887b5761522e62df.tar.bz2
gentoo-21ecc35f5ba74e4ea0f569aa887b5761522e62df.zip
dev-java/freehep-io: Version bump to 2.2.2, EAPI bump, add tests
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-java/freehep-io/freehep-io-2.2.2.ebuild')
-rw-r--r--dev-java/freehep-io/freehep-io-2.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/freehep-io/freehep-io-2.2.2.ebuild b/dev-java/freehep-io/freehep-io-2.2.2.ebuild
new file mode 100644
index 000000000000..ab28fb3da851
--- /dev/null
+++ b/dev-java/freehep-io/freehep-io-2.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="High Energy Physics Java library - FreeHEP I/O Library"
+HOMEPAGE="http://java.freehep.org/"
+SRC_URI="https://github.com/freehep/${PN}/archive/${P}.tar.gz"
+LICENSE="Apache-2.0 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.7
+ test? ( dev-java/junit:4 )"
+
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${P}"
+JAVA_SRC_DIR="src/main/java"
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
+ local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}