summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/freemarker/freemarker-2.3.13-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/freemarker/freemarker-2.3.13-r2.ebuild')
-rw-r--r--dev-java/freemarker/freemarker-2.3.13-r2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-java/freemarker/freemarker-2.3.13-r2.ebuild b/dev-java/freemarker/freemarker-2.3.13-r2.ebuild
new file mode 100644
index 000000000000..9ece82cd09cc
--- /dev/null
+++ b/dev-java/freemarker/freemarker-2.3.13-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION=" FreeMarker is a template engine; a generic tool to generate text output based on templates"
+HOMEPAGE="http://freemarker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="freemarker"
+SLOT="2.3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-java/jython:2.7
+ java-virtuals/servlet-api:2.3
+ java-virtuals/servlet-api:2.4
+ java-virtuals/servlet-api:2.5
+ dev-java/jaxen:1.1
+ dev-java/juel:0"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ dev-java/javacc:0"
+
+# [0]: Patch so that we can compile the package
+# against Jython-2.7.
+# [1]: Gentoo specific stuff.
+PATCHES=(
+ "${FILESDIR}"/${P}-PyJavaInstance.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+java_prepare() {
+ # Do away with bundled jar files.
+ find -name '*.jar' -exec rm -v {} + || die
+
+ # Apply patches.
+ epatch ${PATCHES[@]}
+
+ # Weed out comments (some contain UTF-8 chars javac cannnot deal with).
+ sed -i -e '/*/d;' \
+ src/freemarker/template/LocalizedString.java
+
+ # For ecj-3.5.
+ java-ant_rewrite-bootclasspath auto
+}
+
+src_compile() {
+ # BIG FAT WARNING:
+ # clean target removes lib/ directory!!
+ eant clean
+
+ mkdir -p lib/jsp-{1.2,2.0,2.1} || die
+ pushd lib >/dev/null || die
+ java-pkg_jar-from --virtual --into jsp-1.2 servlet-api-2.3
+ java-pkg_jar-from --virtual --into jsp-2.0 servlet-api-2.4
+ java-pkg_jar-from --virtual --into jsp-2.1 servlet-api-2.5
+ java-pkg_jar-from jaxen-1.1
+ java-pkg_jar-from jython-2.7
+ java-pkg_jar-from --build-only javacc
+ java-pkg_jar-from juel
+ popd >/dev/null
+
+ eant jar $(use_doc) -Djavacc.home=/usr/share/javacc/lib
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ dodoc README.txt
+
+ use doc && java-pkg_dojavadoc build/api
+ use source && java-pkg_dosrc src/*
+}