summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild')
-rw-r--r--dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild
new file mode 100644
index 000000000000..f06c563f37b7
--- /dev/null
+++ b/dev-java/gnu-crypto/gnu-crypto-2.0.1-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU Crypto cryptographic primitives for Java"
+HOMEPAGE="http://www.gnu.org/software/gnu-crypto/"
+SRC_URI="ftp://ftp.gnupg.org/GnuPG/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+EANT_BUILD_XML="${S}/build.xml"
+EANT_BUILD_TARGET="jar"
+
+EANT_DOC_TARGET="javadoc"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ local TEST_TARGETS=(
+ check
+ ent
+ )
+
+ for target in ${TEST_TARGETS[@]}; do
+ EANT_TEST_TARGET=${target} \
+ java-pkg-2_src_test
+ done
+}
+
+src_install() {
+ local GNU_CRYPTO_JARS=(
+ "${PN}"
+ javax-crypto
+ javax-security
+ )
+
+ if use test; then
+ GNU_CRYPTO_JARS=(${GNU_CRYPTO_JARS[@]} "${PN}-test")
+ fi
+
+ for jar in ${GNU_CRYPTO_JARS[@]}; do
+ java-pkg_dojar "lib/${jar}.jar"
+ done
+
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc source/* jce/* security/*
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}