summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-05-10 23:07:06 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-05-11 22:06:22 +0100
commitce6ef532bafd114d4844cebca0a7fe3930ee6775 (patch)
tree13e3e0a0ac9c460ef8e948826590888bc673162a /dev-java/gson/gson-2.6.2.ebuild
parentwww-client/w3mmee: add libressl support (diff)
downloadgentoo-ce6ef532bafd114d4844cebca0a7fe3930ee6775.tar.gz
gentoo-ce6ef532bafd114d4844cebca0a7fe3930ee6775.tar.bz2
gentoo-ce6ef532bafd114d4844cebca0a7fe3930ee6775.zip
dev-java/gson: Version bump to 2.6.2
~x86 keyword added. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/gson/gson-2.6.2.ebuild')
-rw-r--r--dev-java/gson/gson-2.6.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/gson/gson-2.6.2.ebuild b/dev-java/gson/gson-2.6.2.ebuild
new file mode 100644
index 000000000000..d20579bf2778
--- /dev/null
+++ b/dev-java/gson/gson-2.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}-parent-${PV}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to convert JSON to Java objects and vice-versa"
+HOMEPAGE="https://github.com/google/gson"
+SRC_URI="https://github.com/google/${PN}/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${PN}/src/main/java"