summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-10-26 12:10:03 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-10-26 12:10:08 +0200
commit6ff0530bb802ca7958f741297e00291ef861c6a1 (patch)
treec891d8a5c84e358e365a07865737aada4684e083 /dev-java/gson
parentprofiles/base: stable-force media-sound/pulseaudio[daemon] for now (diff)
downloadgentoo-6ff0530bb802ca7958f741297e00291ef861c6a1.tar.gz
gentoo-6ff0530bb802ca7958f741297e00291ef861c6a1.tar.bz2
gentoo-6ff0530bb802ca7958f741297e00291ef861c6a1.zip
dev-java/gson: bump to 2.8.8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/gson')
-rw-r--r--dev-java/gson/Manifest1
-rw-r--r--dev-java/gson/gson-2.8.8.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/gson/Manifest b/dev-java/gson/Manifest
index 2f13307216b1..f2299df636ac 100644
--- a/dev-java/gson/Manifest
+++ b/dev-java/gson/Manifest
@@ -1 +1,2 @@
+DIST gson-2.8.8-sources.tar.gz 393941 BLAKE2B ebdd1088a069eea58e5ea4e2eddea0d42064c53f7284778b1b7217c8bc7abeb7e14350e19d838af1d94f78c5c38aca6de0f37674b022f0e528ed65eef803c3f1 SHA512 f90ad679c99c5e9a6ee9e397e59ab1d7d94a9c82366902b808addc40ebbab101fdba7fc83e4666c4f35e52d8b127e6f901e65072a7de210496466074dcd043c5
DIST gson-parent-2.8.7.tar.gz 391617 BLAKE2B 2c0fa3927d44c4a5c961518955dfbe6fee60dd61026002d0152d25d6f22dd4ac08b4323256af1053d0f17ef5d9f2a2a3ee86cedebd52a112d258e8c8c37e545d SHA512 044032b24ec1198d054807ccbfd91301307992b6e7d03a2e8578be79a2cdb28ba0ba57a954f11ad43022ec696c1522d242ed6b1045f831c9a370e0621e674fe0
diff --git a/dev-java/gson/gson-2.8.8.ebuild b/dev-java/gson/gson-2.8.8.ebuild
new file mode 100644
index 000000000000..d8e2d41c9241
--- /dev/null
+++ b/dev-java/gson/gson-2.8.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom gson/pom.xml --download-uri https://github.com/google/gson/archive/gson-parent-2.8.8.tar.gz --slot 2.6 --keywords "~amd64 ~ppc64 ~x86" --ebuild gson-2.8.8.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.google.code.gson:gson:2.8.8"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Gson JSON library"
+HOMEPAGE="https://github.com/google/gson/gson"
+SRC_URI="https://github.com/google/${PN}/archive/${PN}-parent-${PV}.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: ${PN}/pom.xml
+# test? com.github.wvengen:proguard-maven-plugin:2.4.0 -> !!!groupId-not-found!!!
+# test? junit:junit:4.13.2 -> >=dev-java/junit-4.13.2:4
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${PN}-${PN}-parent-${PV}/${PN}"
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-templates"
+)
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)
+
+JAVA_TEST_EXCLUDES=(
+ # requires the test class to be obfuscated using proguard which we do not have atm
+ "com.google.gson.functional.EnumWithObfuscatedTest"
+)
+
+src_prepare() {
+ default
+ sed -i "s/\${project.version}/${PV}/g" src/main/java-templates/com/google/gson/internal/GsonBuildConfig.java || die "Failed to set version"
+}