summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-09-12 09:32:09 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-09-12 09:32:30 +0000
commite25cca877ca5b331892b043b3666927b612c0b52 (patch)
tree60c41e12cfd495654537fa0a72706c85a277f2c8 /dev-java/guava/guava-13.0.1-r3.ebuild
parentwww-apps/moodle: version bumps, drop older. (diff)
downloadgentoo-e25cca877ca5b331892b043b3666927b612c0b52.tar.gz
gentoo-e25cca877ca5b331892b043b3666927b612c0b52.tar.bz2
gentoo-e25cca877ca5b331892b043b3666927b612c0b52.zip
dev-java/guava: Revert all changes made so far and set up a hard dependency on Java 7. Fixes bug 560042.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/guava/guava-13.0.1-r3.ebuild')
-rw-r--r--dev-java/guava/guava-13.0.1-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/guava/guava-13.0.1-r3.ebuild b/dev-java/guava/guava-13.0.1-r3.ebuild
new file mode 100644
index 000000000000..b29b74c5cd66
--- /dev/null
+++ b/dev-java/guava/guava-13.0.1-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://code.google.com/p/guava-libraries/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="13"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+DEPEND="
+ dev-java/jsr305:0
+ java-virtuals/jdk-with-com-sun:0"
+RDEPEND="${DEPEND}
+ virtual/jre:1.7"
+DEPEND="${DEPEND}
+ app-arch/unzip
+ virtual/jdk:1.7" # https://github.com/google/guava/issues/1738
+JAVA_GENTOO_CLASSPATH="jsr305"