summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-15 08:47:43 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-15 09:02:19 +0000
commit19cf0e25698f62824f77a677111458fcaabe173c (patch)
tree304568358a6f7824aad668502b3d410f87479c1b /dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild
parentdev-lang/crystal: version bump to 0.15.0 (diff)
downloadgentoo-19cf0e25698f62824f77a677111458fcaabe173c.tar.gz
gentoo-19cf0e25698f62824f77a677111458fcaabe173c.tar.bz2
gentoo-19cf0e25698f62824f77a677111458fcaabe173c.zip
dev-java/hamcrest-core: EAPI 5 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild')
-rw-r--r--dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild b/dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild
new file mode 100644
index 000000000000..b3dadf86f5cb
--- /dev/null
+++ b/dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="hamcrest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Library of matchers for building test expressions"
+HOMEPAGE="https://github.com/hamcrest"
+SRC_URI="https://github.com/${MY_PN}/JavaHamcrest/archive/${MY_PN}-java-${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/JavaHamcrest-${MY_PN}-java-${PV}"
+
+JAVA_SRC_DIR="${PN}/src"
+
+java_prepare() {
+ java-pkg_clean
+}