summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/httpunit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/httpunit')
-rw-r--r--dev-java/httpunit/Manifest1
-rw-r--r--dev-java/httpunit/files/rhino-fix-1.6.2.diff25
-rw-r--r--dev-java/httpunit/httpunit-1.7.ebuild56
-rw-r--r--dev-java/httpunit/metadata.xml15
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-java/httpunit/Manifest b/dev-java/httpunit/Manifest
new file mode 100644
index 000000000000..98af4a5986de
--- /dev/null
+++ b/dev-java/httpunit/Manifest
@@ -0,0 +1 @@
+DIST httpunit-1.7.zip 4181983 SHA256 ee178a368f0db6979dfdca24c655f73726c3729fb76dafb064a8fdf8b057f625 SHA512 1d109b8ef65fb80d7904c2786db31916b2ef26c5b92730ce41b90c441d3e8d46a4a8a84a5e82237b52412c6bc29fc6eff18297d2f961616bd8429bf5d579567e WHIRLPOOL 2c397d2a9788812ee413ae682393be9103535942e695a2103ff404fe1a2ec539ed8b22201cdc2c10b011db729f821d91fe100d700b3657600c284d484070b5ce
diff --git a/dev-java/httpunit/files/rhino-fix-1.6.2.diff b/dev-java/httpunit/files/rhino-fix-1.6.2.diff
new file mode 100644
index 000000000000..c439d7183ca0
--- /dev/null
+++ b/dev-java/httpunit/files/rhino-fix-1.6.2.diff
@@ -0,0 +1,25 @@
+diff -Nur httpunit-1.6.2/src/com/meterware/httpunit/javascript/JavaScript.java httpunit-1.6.2_fixed/src/com/meterware/httpunit/javascript/JavaScript.java
+--- httpunit-1.6.2/src/com/meterware/httpunit/javascript/JavaScript.java 2006-03-26 22:16:46.000000000 +0300
++++ httpunit-1.6.2_fixed/src/com/meterware/httpunit/javascript/JavaScript.java 2007-10-14 20:34:03.000000000 +0300
+@@ -838,8 +838,6 @@
+ static ElementArray newElementArray( Scriptable parent ) {
+ try {
+ return (ElementArray) Context.getCurrentContext().newObject( parent, "ElementArray" );
+- } catch (PropertyException e) {
+- throw new RhinoException( e );
+ } catch (NotAFunctionException e) {
+ throw new RhinoException( e );
+ } catch (JavaScriptException e) {
+@@ -1144,10 +1142,10 @@
+
+ class RhinoException extends RuntimeException {
+
+- private Exception _cause;
++ private Throwable _cause;
+
+
+- public RhinoException( Exception cause ) {
++ public RhinoException( Throwable cause ) {
+ _cause = cause;
+ }
+
diff --git a/dev-java/httpunit/httpunit-1.7.ebuild b/dev-java/httpunit/httpunit-1.7.ebuild
new file mode 100644
index 000000000000..653407b99ccf
--- /dev/null
+++ b/dev-java/httpunit/httpunit-1.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="HttpUnit emulates the relevant portions of browser behavior"
+HOMEPAGE="http://httpunit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND="
+ >=dev-java/junit-3.8:0
+ dev-java/rhino:1.6
+ dev-java/jtidy:0
+ java-virtuals/servlet-api:2.3
+ dev-java/xerces:2"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+java_prepare() {
+ find . -name "*.jar" | xargs rm -v
+
+ epatch "${FILESDIR}/rhino-fix-1.6.2.diff"
+
+ cd jars || die
+ java-pkg_jar-from junit,rhino-1.6,xerces-2,jtidy,servlet-api-2.3
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+
+ eant clean jar $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar "lib/${PN}.jar"
+
+ dodoc doc/*.txt
+
+ if use doc; then
+ dohtml -r doc/manual doc/tutorial
+ java-pkg_dojavadoc doc/api
+ fi
+}
diff --git a/dev-java/httpunit/metadata.xml b/dev-java/httpunit/metadata.xml
new file mode 100644
index 000000000000..4c66010521dc
--- /dev/null
+++ b/dev-java/httpunit/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ HttpUnit emulates the relevant portions of browser behavior,
+ including form submission, JavaScript, basic http authentication,
+ cookies and automatic page redirection, and allows Java test code
+ to examine returned pages either as text, an XML DOM, or containers
+ of forms, tables, and links.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">httpunit</remote-id>
+ </upstream>
+</pkgmetadata>