summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ical4j
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ical4j')
-rw-r--r--dev-java/ical4j/Manifest1
-rw-r--r--dev-java/ical4j/files/1.0.5-build.xml.patch80
-rw-r--r--dev-java/ical4j/ical4j-1.0.5.ebuild58
-rw-r--r--dev-java/ical4j/metadata.xml21
4 files changed, 160 insertions, 0 deletions
diff --git a/dev-java/ical4j/Manifest b/dev-java/ical4j/Manifest
new file mode 100644
index 000000000000..e9be8f8240b9
--- /dev/null
+++ b/dev-java/ical4j/Manifest
@@ -0,0 +1 @@
+DIST ical4j-1.0.5-src.tar.bz2 9307268 SHA256 7fe8bd596489f3f015b904794fb9d9a346823e1750619ec71d6929ba870293f7 SHA512 1c2c1eb6207094fd12036d4eb93afaef820c19c7bce99611ddb9115cd62ece76972b7280364b49643147e4456ef4afca4df23ce4413e0288804183f33c2cc286 WHIRLPOOL 80b71c87bddbe5001f58203b2648a467d766f5dc8b16211d8f45f6770ec7037bab260165c1c526218bf73352884dd24be62b1d58c6d6278b06254fd651831b48
diff --git a/dev-java/ical4j/files/1.0.5-build.xml.patch b/dev-java/ical4j/files/1.0.5-build.xml.patch
new file mode 100644
index 000000000000..7e68876616d8
--- /dev/null
+++ b/dev-java/ical4j/files/1.0.5-build.xml.patch
@@ -0,0 +1,80 @@
+diff --git a/ical4j-1.0.5/build.xml b/ical4j-1.0.5/build.xml
+index 512738c..be5aac9 100644
+--- a/ical4j-1.0.5/build.xml
++++ b/ical4j-1.0.5/build.xml
+@@ -14,7 +14,7 @@
+ <property file="build.properties" />
+
+ <!-- Project paths -->
+- <property name="source.dir" location="source" />
++ <property name="source.dir" location="src" />
+ <property name="test.source.dir" location="test" />
+ <property name="output.dir" location="bin" />
+ <property name="package.dir" location="build" />
+@@ -99,7 +99,7 @@
+ <echo message="Compiling source from classpath: ${project.classpath}" />
+ <mkdir dir="${output.dir}" />
+
+- <copy file="${source.dir}/net/fortuna/ical4j/model/tz.alias" todir="${output.dir}/net/fortuna/ical4j/model" />
++ <copy file="src/main/resources/net/fortuna/ical4j/model/tz.alias" todir="${output.dir}/net/fortuna/ical4j/model" />
+
+ <javac source="1.4" target="1.4" srcdir="${source.dir}" destdir="${output.dir}" debug="true" debuglevel="lines,source,vars" deprecation="true" classpathref="project.classpath" />
+ </target>
+@@ -123,7 +123,7 @@
+ <attribute name="Class-Path" value="commons-logging.jar,commons-codec.jar,commons-lang.jar" />
+ </manifest>
+ <jar basedir="${output.dir}" compress="true" jarfile="${package.dir}/${package.file}" manifest="etc/manifest.mf">
+- <zipfileset dir="etc/zoneinfo" prefix="zoneinfo" excludes="zones.h,zones.tab" />
++ <zipfileset dir="/usr/share/zoneinfo" prefix="zoneinfo" excludes="zones.h,zones.tab" />
+ </jar>
+ </target>
+
+@@ -187,10 +187,8 @@
+ <instr instrpathref="coverage.classpath" destdir="${out.instr.dir}" metadatafile="${coverage.dir}/metadata.emma" merge="true" />
+ </emma>
+
+- <junit printsummary="withOutAndErr" showoutput="yes" fork="yes">
+- <!--
+- <classpath path="${project.classpath}"/>
+- -->
++ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
++
+ <classpath>
+ <pathelement location="${out.instr.dir}" />
+ <path refid="coverage.classpath" />
+@@ -198,22 +196,19 @@
+ </classpath>
+ <jvmarg value="-Demma.coverage.out.file=${coverage.dir}/coverage.emma" />
+ <jvmarg value="-Demma.coverage.out.merge=false" />
+- <test name="net.fortuna.ical4j.AllTests" />
+- <!--
+- <batchtest>
+- <fileset dir="${test.source.dir}">
+- <include name="**/*Test.java"/>
+- </fileset>
+- </batchtest>
+- -->
+-
+- <!--
+- <test name="net.fortuna.ical4j.data.CalendarOutputterTest"/>
+- <test name="net.fortuna.ical4j.model.component.VTimeZoneTest"/>
+- <test name="net.fortuna.ical4j.model.component.VEventTest"/>
+- <test name="net.fortuna.ical4j.data.CalendarBuilderTest"/>
+- -->
+- </junit>
++
++
++ <sysproperty key="basedir" value="."/>
++ <formatter type="xml"/>
++ <formatter type="plain" usefile="false"/>
++
++ <batchtest>
++ <fileset dir="${test.source.dir}">
++ <include name="**/*Test.java"/>
++ <exclude name="**/*Abstract*Test.java"/>
++ </fileset>
++ </batchtest>
++ </junit>
+
+ <emma enabled="${emma.enabled}">
+ <report sourcepath="${src.dir}">
diff --git a/dev-java/ical4j/ical4j-1.0.5.ebuild b/dev-java/ical4j/ical4j-1.0.5.ebuild
new file mode 100644
index 000000000000..1ae24297ff55
--- /dev/null
+++ b/dev-java/ical4j/ical4j-1.0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="a Java library for handling iCalendar data streams"
+HOMEPAGE="http://ical4j.sourceforge.net/"
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+COMMON_DEP="
+ dev-java/commons-logging:0
+ dev-java/commons-codec:0
+ dev-java/commons-lang:2.1
+ dev-java/backport-util-concurrent:0"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/emma:0
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PV}-build.xml.patch
+ rm -v lib/*.jar || die "rm jar failed"
+ #mkdir bin || die "mkdir bin failed"
+ java-pkg_filter-compiler jikes
+}
+
+EANT_ANT_TASKS="emma"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="package"
+EANT_GENTOO_CLASSPATH="commons-logging,commons-codec,commons-lang-2.1,backport-util-concurrent"
+EANT_EXTRA_ARGS="-Demma.dir=/usr/share/emma/lib/ -Dsource.dir=src/main/java"
+
+RESTRICT="test"
+# two tests fail with maven, they work in HEAD
+
+src_install() {
+ java-pkg_dojar build/*.jar
+ dodoc README AUTHORS CHANGELOG etc/FAQ \
+ etc/TODO etc/standard_deviations.txt
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/main/java/net
+ use examples && java-pkg_doexamples etc/samples
+}
diff --git a/dev-java/ical4j/metadata.xml b/dev-java/ical4j/metadata.xml
new file mode 100644
index 000000000000..fb19e8790932
--- /dev/null
+++ b/dev-java/ical4j/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ iCal4j is a Java library used to read and write iCalendar data streams
+ as defined in RFC2445. The iCalendar standard provides a common data
+ format used to store information about calendar-specific data such as
+ events, appointments, to-do lists, etc. All of the popular calendaring
+ tools, such as Lotus Notes, Outlook and Apple's iCal also support the
+ iCalendar standard.
+
+ Providing both a parser and an object model, iCal4j allows you to either
+ modify existing iCalendar data or create new data models. Validation is
+ also provided to ensure the data maintains a state consistent with the
+ specification.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ical4j</remote-id>
+ </upstream>
+</pkgmetadata>