summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-09 14:54:38 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-09 14:54:38 +0200
commit286401c631ff8ea6ae71d7272fcf56b98b42ee42 (patch)
treedd77435ea31c51612d12e2c3a105aa68084e2f85 /dev-java/jakarta-activation
parentdev-java/jakarta-activation: new package (diff)
downloadgentoo-286401c631ff8ea6ae71d7272fcf56b98b42ee42.tar.gz
gentoo-286401c631ff8ea6ae71d7272fcf56b98b42ee42.tar.bz2
gentoo-286401c631ff8ea6ae71d7272fcf56b98b42ee42.zip
dev-java/jakarta-activation: cleanup + comments
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jakarta-activation')
-rw-r--r--dev-java/jakarta-activation/jakarta-activation-1.2.2.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-java/jakarta-activation/jakarta-activation-1.2.2.ebuild b/dev-java/jakarta-activation/jakarta-activation-1.2.2.ebuild
index a4376b8ad43d..6c2ae11e3b08 100644
--- a/dev-java/jakarta-activation/jakarta-activation-1.2.2.ebuild
+++ b/dev-java/jakarta-activation/jakarta-activation-1.2.2.ebuild
@@ -43,13 +43,11 @@ src_prepare() {
src_compile() {
java-pkg-simple_src_compile
- # we remove API classes from the api
- zip -d ${PN}.jar "javax/*" || die "Failed to remove implementation classes"
-}
-src_install() {
- default
- # we remove the API sources so that they don't land in sources
-# rm -fr ${JAVA_SRC_DIR}/javax || "Failed to delete implementation sources"
- java-pkg-simple_src_install
+ # we remove API classes from the jar file
+ # removing javax sources in src_prepare does not work - compilation fails with:
+ # src/main/java/module-info.java:12: error: package is empty or does not exist: javax.activation
+ # exports javax.activation;
+
+ zip -d ${PN}.jar "javax/*" || die "Failed to remove API classes"
}