summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-12-14 09:50:04 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-17 09:58:56 +0100
commitefd93be2c628aaeb5573aec651a9388ac7276387 (patch)
tree5de0c3013ab7d8cd5af61ea6efe578de5d1bde7a /dev-java/jansi
parentx11-terms/kitty-terminfo: stabilize 0.23.1-r1 for x86 (diff)
downloadgentoo-efd93be2c628aaeb5573aec651a9388ac7276387.tar.gz
gentoo-efd93be2c628aaeb5573aec651a9388ac7276387.tar.bz2
gentoo-efd93be2c628aaeb5573aec651a9388ac7276387.zip
dev-java/jansi: bump to 2.4.0
SLOT="2" since jline does not compile with it. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/23804 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/Manifest1
-rw-r--r--dev-java/jansi/jansi-2.4.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-java/jansi/Manifest b/dev-java/jansi/Manifest
index 31fabc8cd4c4..1325190f77b1 100644
--- a/dev-java/jansi/Manifest
+++ b/dev-java/jansi/Manifest
@@ -1 +1,2 @@
DIST jansi-1.13.tar.gz 253219 BLAKE2B 89fc81710bc0860c717241c97fe2e7a148ccbaa5fb1e7db30b978aa69cddccbc9ea45a0e30ef384c42a741d707f5eab73ce8b2a76e1095c66a2c95f9088f28f0 SHA512 9c4bb0b7435c102068718e039900828994f1ba60ed44307eb726eb91a2884bc406688c2747635b9353f3bd68a6bf0e7c082a4069343b59efffc900f59c563fde
+DIST jansi-2.4.0.tar.gz 225579 BLAKE2B f07dfde9b789d62ec31999632e35609143289c5ab0972ce7cb931dea72ba41e6f2b9b74f7b3d82050e9ed4abd89386040d5268c408d787d3edd49fcdf0cce965 SHA512 4172b264463b847d6008dfad5c80246b029c7add2fd659f4b1c636891a86860f8f5ddd0ce0a5150065faeae72b19682339dda2d019c82f45d8f1be7a547e4558
diff --git a/dev-java/jansi/jansi-2.4.0.ebuild b/dev-java/jansi/jansi-2.4.0.ebuild
new file mode 100644
index 000000000000..e93adc8efc55
--- /dev/null
+++ b/dev-java/jansi/jansi-2.4.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fusesource/jansi/archive/refs/tags/jansi-2.4.0.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jansi-2.4.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.fusesource.jansi:jansi:2.4.0"
+
+inherit java-pkg-2 java-pkg-simple toolchain-funcs
+
+DESCRIPTION="Jansi is a java library for generating and interpreting ANSI escape sequences."
+HOMEPAGE="http://fusesource.github.io/jansi"
+SRC_URI="https://github.com/fusesource/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? info.picocli:picocli-codegen:4.5.2 -> !!!artifactId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.0 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-params:5.7.0 -> !!!groupId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+# junit-jupiter is not available in ::gentoo
+# test? (
+# !!!artifactId-not-found!!!
+# !!!groupId-not-found!!!
+# )
+#"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,readme}.md license.txt )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+JAVA_MAIN_CLASS="org.fusesource.jansi.AnsiMain"
+
+# junit-jupiter is not available in ::gentoo
+#JAVA_TEST_GENTOO_CLASSPATH="!!!artifactId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!"
+#JAVA_TEST_SRC_DIR="src/test/java"
+#JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+src_prepare() {
+ default
+ # Remove this directory containing libjansi.so, libjansi.jnilib and jansi.dll
+ rm -r "${JAVA_RESOURCE_DIRS}/org/fusesource/jansi/internal/native" || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ # build native library.
+ local args=(
+ CCFLAGS="${CFLAGS} ${CXXFLAGS} -Os -fPIC -fvisibility=hidden"
+ LINKFLAGS="-shared"
+ CC="$(tc-getCC)"
+ STRIP="$(tc-getSTRIP)"
+ LIBNAME="libjansi-$(ver_cut 1-2).so"
+ )
+ emake "${args[@]}" native
+}
+
+src_install() {
+ # default # https://bugs.gentoo.org/789582
+ # deafult fails with
+ # make: *** No rule to make target 'install'. Stop.
+ java-pkg_doso target/native--/libjansi-$(ver_cut 1-2).so
+ java-pkg-simple_src_install
+}