summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/java-gnome/java-gnome-4.0.19.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/java-gnome/java-gnome-4.0.19.ebuild')
-rw-r--r--dev-java/java-gnome/java-gnome-4.0.19.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-java/java-gnome/java-gnome-4.0.19.ebuild b/dev-java/java-gnome/java-gnome-4.0.19.ebuild
new file mode 100644
index 000000000000..0f4e14d4219b
--- /dev/null
+++ b/dev-java/java-gnome/java-gnome-4.0.19.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils versionator java-pkg-2 multilib
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Java bindings for GTK and GNOME"
+HOMEPAGE="http://java-gnome.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="4.0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-2.22.0:2
+ >=gnome-base/libglade-2.6.4
+ >=gnome-base/libgnome-2.22.0
+ >=gnome-base/gnome-desktop-2.22.0:2
+ >=x11-libs/cairo-1.10.0[svg]
+ >=x11-libs/gtksourceview-2.6.2:2.0
+ >=app-text/gtkspell-2.0.15-r1:2
+ >=x11-libs/libnotify-0.4.5
+ >=dev-libs/libunique-1.0.8:1
+ >=gnome-base/librsvg-2.32.1
+ dev-libs/atk
+ >=virtual/jre-1.5"
+DEPEND="${RDEPEND}
+ dev-java/junit:0
+ dev-lang/perl
+ virtual/pkgconfig
+ >=virtual/jdk-1.5"
+
+# Needs X11
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ if has_version ">=x11-libs/libnotify-0.7"; then
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ fi
+}
+
+src_configure() {
+ # Handwritten in perl so not using econf
+ ./configure prefix=/usr libdir=/usr/$(get_libdir)/${PN}-${SLOT} jardir=/usr/share/${PN}-${SLOT}/lib || die
+}
+
+src_compile() {
+ # Fails parallel build in case GCJ is detected
+ # See https://bugs.gentoo.org/show_bug.cgi?id=200550
+ emake -j1 || die "Compilation of java-gnome failed"
+
+ if use doc; then
+ DISPLAY= emake -j1 doc || die "Making documentation failed"
+ fi
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die
+ java-pkg_regjar /usr/share/${PN}-${SLOT}/lib/gtk-${SLOT}.jar
+ java-pkg_regjar /usr/share/${PN}-${SLOT}/lib/gtk.jar
+
+ dodoc AUTHORS HACKING NEWS README || die
+ use doc && java-pkg_dojavadoc doc/api
+ use examples && java-pkg_doexamples doc/examples
+ use source && java-pkg_dosrc src/bindings/org
+}