summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-10-19 10:56:29 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-10-19 10:57:16 +0100
commit1e705da2e4c503ab67f7db988052f74d754d6058 (patch)
treeae298fe4aa88642f5f835fc281df8ae825bb4c98 /dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild
parentsys-libs/tevent: Bump to version 0.9.31 (diff)
downloadgentoo-1e705da2e4c503ab67f7db988052f74d754d6058.tar.gz
gentoo-1e705da2e4c503ab67f7db988052f74d754d6058.tar.bz2
gentoo-1e705da2e4c503ab67f7db988052f74d754d6058.zip
dev-java/java-sdk-docs: Version bump to 1.8.0.112
Straight to stable as the old version has gone. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild
new file mode 100644
index 000000000000..d858508a6b54
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.112.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm ~ppc64 x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}