summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-12-10 21:42:32 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-12-10 21:46:11 +0000
commit678ff3c01e80fe437b1bf669aa8811b3bcbfef62 (patch)
tree4575a5aac7d2bc3be4fb381a6f3c3b5f30611663 /dev-java/java-sdk-docs
parentlicenses: Add oracle-java-documentation-9 for Java 9 (diff)
downloadgentoo-678ff3c01e80fe437b1bf669aa8811b3bcbfef62.tar.gz
gentoo-678ff3c01e80fe437b1bf669aa8811b3bcbfef62.tar.bz2
gentoo-678ff3c01e80fe437b1bf669aa8811b3bcbfef62.zip
dev-java/java-sdk-docs: Version bump to 9.0.1 (Java 9)
I have decided to install to /usr/share/doc/${PN}-${SLOT} because the sheer size of this means you briefly have an extra 400MB taken up before the old version is removed. A more static location can be useful anyhow. Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/Manifest3
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-9.0.1.ebuild37
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/Manifest b/dev-java/java-sdk-docs/Manifest
index ac2f8ca4de68..88683fb45ac9 100644
--- a/dev-java/java-sdk-docs/Manifest
+++ b/dev-java/java-sdk-docs/Manifest
@@ -1,2 +1,3 @@
DIST jdk-7u80-docs-all.zip 61168809 SHA256 0494bd49bc9cb3cbe3203120ae8b2c8e0aeb1579cb15c0fbd3cd780d19aa200a SHA512 c673c00e55c9a19938c42512cb9c6ae65de9803a1307d11a2043903d87cc36d9ed1f5a1e287040d8570e430cfe55f496354c1242fe6e242f1245f8271394ea1a WHIRLPOOL ad18886c401ec42735665081a0dd5ba3dc7678de0171f3aa8151c2e4ce3392e467be65c602f393da38373e589fa9800ed1afd3601d2cef4e48b06e57f491698e
-DIST jdk-8u152-docs-all.zip 93495668 SHA256 68d1f0f7827d86c6309b04c0f089c219f203158e993a88b47a6acaa0e4b40823 SHA512 5aa49103685fc466bf2c5ff32aeee9ccf5b51359bb8e558bc8f23dc399fb108cba7fd282b669ce3b8062865fc4507afc809f8fb0ca844587eb168ad44c69ad77 WHIRLPOOL a0eff7c33c37c286a69e03340e1ccf5f4c59be40f0a03ff9c800960c2a26971cee22b94829bd1b064b77332b17590969cbcc31f291b7f8da0eebd63e5009aeeb
+DIST jdk-8u152-docs-all.zip 93495668 BLAKE2B 9bb791ef4ace0fd180953e12501900a21583cf9cd8c256246c0d8b1fe139aa7c21fffd073cf6cfc27c206f00eb9d77fd510f8ced752f7c690a4762a9f52f3e8d SHA512 5aa49103685fc466bf2c5ff32aeee9ccf5b51359bb8e558bc8f23dc399fb108cba7fd282b669ce3b8062865fc4507afc809f8fb0ca844587eb168ad44c69ad77
+DIST jdk-9.0.1_doc-all.zip 70497837 BLAKE2B 437aeae172d5a2133eb34f305925898aa80b52f15ae9860d148e3eda7de34b635c4defa0683009c4232658414c81d1f01fbea4201ea179347508caf63d13cd82 SHA512 c031497e5644abe9e9d72f9b2af6c11cf9842ee2f1001184704d994ec62b46a3620930e63944253c777d8ec9248418369579e439cf5c13c66805364669e54063
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-9.0.1.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-9.0.1.ebuild
new file mode 100644
index 000000000000..865ee06d1665
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-9.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk9-doc-downloads-3850606.html"
+
+SLOT="${PV%%.*}"
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="https://docs.oracle.com/javase/${SLOT}"
+SRC_URI="jdk-${PV}_doc-all.zip"
+LICENSE="oracle-java-documentation-${SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from"
+ einfo "${DOWNLOAD_URL}"
+ einfo "by agreeing to the license and place it in ${DISTDIR}"
+ einfo ""
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report it in bug #67266 (link below)."
+ einfo ""
+ einfo "If emerge fails because of a checksum error, it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}/html
+ doins -r index.html */
+}