summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/javacc/javacc-4.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/javacc/javacc-4.2.ebuild')
-rw-r--r--dev-java/javacc/javacc-4.2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-java/javacc/javacc-4.2.ebuild b/dev-java/javacc/javacc-4.2.ebuild
new file mode 100644
index 000000000000..7b0cecd3b720
--- /dev/null
+++ b/dev-java/javacc/javacc-4.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Java Compiler Compiler - The Java Parser Generator"
+HOMEPAGE="https://javacc.dev.java.net/"
+SRC_URI="https://${PN}.dev.java.net/files/documents/17/117795/${P}src.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+DEPEND=">=virtual/jdk-1.5
+ dev-java/junit:0
+ test? (
+ >=virtual/jdk-1.5
+ dev-java/ant-junit
+ )
+ !test? ( >=virtual/jdk-1.4 )"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/junit:0"
+
+# We don't want 1.5 bytecode just because of the testcase
+JAVA_PKG_WANT_TARGET="1.4"
+JAVA_PKG_WANT_SOURCE="1.4"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.0-javadoc.patch
+ rm -v lib/junit*/*.jar || die
+}
+
+_eant() {
+ eant -Djunit.jar="$(java-pkg_getjar --build-only junit junit.jar)" "${@}"
+}
+
+src_compile() {
+ _eant jar $(use_doc)
+}
+
+src_test() {
+ # this testcase wants 1.5 and this seems the easiest way to do it
+ JAVA_PKG_WANT_SOURCE="1.5" JAVA_PKG_WANT_TARGET="1.5" java-ant_bsfix_one examples/JavaGrammars/1.5/build.xml
+ ANT_TASKS="ant-junit" _eant test
+}
+
+src_install() {
+ java-pkg_dojar bin/lib/${PN}.jar
+
+ dodoc README || die
+
+ if use doc; then
+ java-pkg_dohtml -r www/*
+ java-pkg_dojavadoc doc/api
+ fi
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -R examples/* "${D}"/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/*
+
+ echo "JAVACC_HOME=/usr/share/javacc/" > "${T}"/22javacc
+ doenvd "${T}"/22javacc
+
+ echo "export VERSION=${PV}" > "${T}"/pre
+
+ local launcher
+ for launcher in javacc jjdoc jjtree
+ do
+ java-pkg_dolauncher ${launcher} -pre "${T}"/pre --main ${launcher}
+ done
+}