summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-02-28 10:07:02 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-03-01 08:17:26 +0100
commitd1d003671a518b454608ec4e2aed248dae13a6e0 (patch)
treeba04b2440bc71d093676b383ae3ddd11177e48ee /dev-java/javahelp
parentdev-java/javax-jsp-api: v2.2 DESCRIPTION (diff)
downloadgentoo-d1d003671a518b454608ec4e2aed248dae13a6e0.tar.gz
gentoo-d1d003671a518b454608ec4e2aed248dae13a6e0.tar.bz2
gentoo-d1d003671a518b454608ec4e2aed248dae13a6e0.zip
dev-java/javahelp: use javax-{jsp,servlet}-api instead of tomcat-*
- min jre-1.8:* - drops keywords, dependencies are not yet keyworded. Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/29851 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/javahelp')
-rw-r--r--dev-java/javahelp/javahelp-2.0.05_p20170719-r3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/javahelp/javahelp-2.0.05_p20170719-r3.ebuild b/dev-java/javahelp/javahelp-2.0.05_p20170719-r3.ebuild
new file mode 100644
index 000000000000..22bd218ccce3
--- /dev/null
+++ b/dev-java/javahelp/javahelp-2.0.05_p20170719-r3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="3ca862d8626096770598a3a256886d205246f4a4"
+JAVA_PKG_IUSE="examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The JavaHelp system online help system"
+HOMEPAGE="https://javaee.github.io/javahelp/"
+SRC_URI="https://github.com/javaee/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="
+ dev-java/javax-jsp-api:2.0
+ dev-java/javax-servlet-api:2.5
+"
+
+RDEPEND=">=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+DEPEND="virtual/jdk:1.8
+ ${CDEPEND}"
+
+JAVA_PKG_NV_DEPEND="virtual/jdk:1.8"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+_eant() {
+ local \
+ servlet_jar=$(java-pkg_getjars javax-servlet-api-2.5) \
+ jsp_jar=$(java-pkg_getjars javax-jsp-api-2.0)
+
+ eant \
+ -f javahelp_nbproject/build.xml \
+ -Dfile.reference.servlet-api.jar="${servlet_jar}" \
+ -Dfile.reference.jsp-api.jar="${jsp_jar}" \
+ -Dservlet-jar="${servlet_jar}" \
+ -Djsp-jar="${jsp_jar}" \
+ -Dservlet-jar-present=true \
+ -Djsp-jar-present=true \
+ -Dtomcat-zip-present=true \
+ ${@}
+}
+
+src_compile() {
+ _eant release
+}
+
+#Does not actually run anything
+#src_test() {
+# _eant test
+#}
+
+src_install() {
+ java-pkg_dojar javahelp_nbproject/dist/lib/*.jar
+
+ java-pkg_dolauncher jhsearch \
+ --main com.sun.java.help.search.QueryEngine
+ java-pkg_dolauncher jhindexer \
+ --main com.sun.java.help.search.Indexer
+
+ use source && java-pkg_dosrc \
+ jhMaster/JSearch/*/com \
+ jhMaster/JavaHelp/src/*/{javax,com}
+
+ use examples && java-pkg_doexamples jhMaster/JavaHelp/demos
+}