summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jaxb/jaxb-2.1.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jaxb/jaxb-2.1.2-r1.ebuild')
-rw-r--r--dev-java/jaxb/jaxb-2.1.2-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/jaxb/jaxb-2.1.2-r1.ebuild b/dev-java/jaxb/jaxb-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..6320cadaa8c6
--- /dev/null
+++ b/dev-java/jaxb/jaxb-2.1.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="1"
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Reference implementation of the JAXB specification"
+HOMEPAGE="http://jaxb.dev.java.net/"
+DATE="20070125"
+MY_P="JAXB2_src_${DATE}"
+SRC_URI="https://jaxb.dev.java.net/${PV}/${MY_P}.jar"
+
+LICENSE="CDDL"
+SLOT="2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/istack-commons-runtime:0
+ dev-java/jsr173:0
+ java-virtuals/jaf
+ dev-java/txw2-runtime:0"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/jaxb-ri-${DATE}"
+
+src_unpack() {
+ echo "A" | java -jar "${DISTDIR}/${A}" -console > /dev/null || die "unpack failed"
+
+ # Source is missing Messages.properties, copy it from binary version:
+ cd "${T}"
+ unzip -qq "${S}/lib/jaxb-api.jar"
+ for mp in $(find javax -name '*.properties'); do
+ mv "${mp}" "${S}/src/${mp}" || die
+ done
+
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jarfrom --build-only ant-core
+ java-pkg_jarfrom istack-commons-runtime
+ java-pkg_jarfrom jsr173
+ java-pkg_jarfrom jaf
+ java-pkg_jarfrom txw2-runtime
+ ln -s $(java-config --tools) || die
+
+ cd "${S}/src/com/sun/"
+ rm -rf codemodel # in dev-java/codemodel
+ rm -rf tools # in dev-java/jaxb-tools
+
+ cp -v "${FILESDIR}/build.xml-${PV}" "${S}/build.xml" || die "cp failed"
+
+}
+
+src_install() {
+ java-pkg_dojar jaxb-api.jar
+ java-pkg_dojar jaxb-impl.jar
+
+ use source && java-pkg_dosrc src/*
+
+}