summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jboss-logging
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jboss-logging')
-rw-r--r--dev-java/jboss-logging/Manifest1
-rw-r--r--dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml224
-rw-r--r--dev-java/jboss-logging/files/jboss-logging-3.1.4-MDC.patch152
-rw-r--r--dev-java/jboss-logging/files/jboss-logging-3.1.4-build.xml202
-rw-r--r--dev-java/jboss-logging/jboss-logging-3.1.4.ebuild52
-rw-r--r--dev-java/jboss-logging/metadata.xml9
6 files changed, 640 insertions, 0 deletions
diff --git a/dev-java/jboss-logging/Manifest b/dev-java/jboss-logging/Manifest
new file mode 100644
index 000000000000..b81da140abe8
--- /dev/null
+++ b/dev-java/jboss-logging/Manifest
@@ -0,0 +1 @@
+DIST jboss-logging-3.1.4.tar.gz 25018 SHA256 805053336b77c4c62e89a920ef9b80cfc6577964fcdcadb7c3ab43b017e1c734 SHA512 633b18b079089444a5f7406a6a2b29100abd2c752306ada4fda0c15f07a60a363d67616e2521ec079f1df37ecdadcbb46e26819a9f5647e3d1a18219c494b73a WHIRLPOOL b60657d39425309c7917a9019b957d83898462c142bdfd95fe5ba1d8c91cb6b0d119515810747f68db15623d389f955c8a1adaafbebb58860570ad9994bffb14
diff --git a/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml b/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml
new file mode 100644
index 000000000000..f024bcc74854
--- /dev/null
+++ b/dev-java/jboss-logging/files/jboss-logging-3.1.3-r1-build.xml
@@ -0,0 +1,224 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/8/14 3:59 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jboss-logging-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jboss-logging-3.1.3.GA"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <doctitle>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</doctitle>
+ <header>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</header>
+ <footer>&lt;![CDATA[JBoss Logging 3.1.3.GA]]&gt;</footer>
+ <bottom>&lt;![CDATA[&lt;i&gt;Copyright &amp;#169; 2012 Red Hat, Inc.&lt;/i&gt;]]&gt;</bottom>
+ <link href="http://java.sun.com/javase/6/docs/api/"/>
+ <doclet name="net.gleamynode.apiviz.APIviz"
+ path="${maven.repo.local}/org/jboss/apiviz/apiviz/1.2.5.GA/apiviz-1.2.5.GA.jar"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="true"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA"/>
+ <get src="http://repo.maven.apache.org/maven2/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"
+ dest="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/log4j/log4j/1.2.16"/>
+ <get src="http://repo.maven.apache.org/maven2/log4j/log4j/1.2.16/log4j-1.2.16.jar"
+ dest="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1"/>
+ <get src="http://repo.maven.apache.org/maven2/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"
+ dest="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jboss-logging/files/jboss-logging-3.1.4-MDC.patch b/dev-java/jboss-logging/files/jboss-logging-3.1.4-MDC.patch
new file mode 100644
index 000000000000..e8a3a50a41fd
--- /dev/null
+++ b/dev-java/jboss-logging/files/jboss-logging-3.1.4-MDC.patch
@@ -0,0 +1,152 @@
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/AbstractMdcLoggerProvider.java.orig 2015-05-17 20:55:35.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/AbstractMdcLoggerProvider.java 2015-05-17 20:58:00.000000000 +0000
+@@ -23,27 +23,27 @@
+
+ abstract class AbstractMdcLoggerProvider extends AbstractLoggerProvider {
+
+- private final ThreadLocal<Map<String, Object>> mdcMap = new ThreadLocal<Map<String, Object>>();
++ private final ThreadLocal<Map<String, String>> mdcMap = new ThreadLocal<Map<String, String>>();
+
+ public Object getMdc(String key) {
+ return mdcMap.get() == null ? null : mdcMap.get().get(key);
+ }
+
+- public Map<String, Object> getMdcMap() {
++ public Map<String, String> getMdcMap() {
+ return mdcMap.get();
+ }
+
+- public Object putMdc(String key, Object value) {
+- Map<String, Object> map = mdcMap.get();
++ public Object putMdc(String key, String value) {
++ Map<String, String> map = mdcMap.get();
+ if (map == null) {
+- map = new HashMap<String, Object>();
++ map = new HashMap<String, String>();
+ mdcMap.set(map);
+ }
+ return map.put(key, value);
+ }
+
+ public void removeMdc(String key) {
+- Map<String, Object> map = mdcMap.get();
++ Map<String, String> map = mdcMap.get();
+ if (map == null)
+ return;
+ map.remove(key);
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/Log4jLoggerProvider.java.orig 2015-05-17 20:16:57.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/Log4jLoggerProvider.java 2015-05-17 21:21:25.157000000 +0000
+@@ -34,11 +34,11 @@
+ }
+
+ @SuppressWarnings("unchecked")
+- public Map<String, Object> getMdcMap() {
++ public Map<String, String> getMdcMap() {
+ return MDC.getContext();
+ }
+
+- public Object putMdc(String key, Object val) {
++ public Object putMdc(String key, String val) {
+ try {
+ return MDC.get(key);
+ } finally {
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/Slf4jLoggerProvider.java.orig 2015-05-17 20:44:24.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/Slf4jLoggerProvider.java 2015-05-17 21:22:05.205000000 +0000
+@@ -33,14 +33,14 @@
+ return new Slf4jLogger(name, l);
+ }
+
+- public Object putMdc(final String key, final Object value) {
++ public Object putMdc(final String key, final String value) {
+ try {
+ return MDC.get(key);
+ } finally {
+ if (value == null) {
+ MDC.remove(key);
+ } else {
+- MDC.put(key, String.valueOf(value));
++ MDC.put(key, value);
+ }
+ }
+ }
+@@ -54,7 +54,7 @@
+ }
+
+ @SuppressWarnings({ "unchecked" })
+- public Map<String, Object> getMdcMap() {
++ public Map<String, String> getMdcMap() {
+ return MDC.getCopyOfContextMap();
+ }
+ }
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/JDKLoggerProvider.java.orig 2015-05-17 21:19:12.964000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/JDKLoggerProvider.java 2015-05-17 21:22:41.639000000 +0000
+@@ -23,4 +23,9 @@
+ public Logger getLogger(final String name) {
+ return new JDKLogger(name);
+ }
++
++ @Override
++ public Object putMdc(String key, String value) {
++ return null;
++ }
+ }
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/JBossLogManagerProvider.java.orig 2015-05-17 20:15:41.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/JBossLogManagerProvider.java 2015-05-17 21:20:42.844000000 +0000
+@@ -59,8 +59,8 @@
+ }
+ }
+
+- public Object putMdc(final String key, final Object value) {
+- return MDC.put(key, String.valueOf(value));
++ public Object putMdc(final String key, final String value) {
++ return MDC.put(key, value);
+ }
+
+ public Object getMdc(final String key) {
+@@ -72,7 +72,7 @@
+ }
+
+ @SuppressWarnings({ "unchecked" })
+- public Map<String, Object> getMdcMap() {
++ public Map<String, String> getMdcMap() {
+ // we can re-define the erasure of this map because MDC does not make further use of the copy
+ return (Map)MDC.copy();
+ }
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/MDC.java.orig 2015-05-17 19:12:40.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/MDC.java 2015-05-17 21:22:27.689000000 +0000
+@@ -25,7 +25,7 @@
+ private MDC() {
+ }
+
+- public static Object put(String key, Object val) {
++ public static Object put(String key, String val) {
+ return LoggerProviders.PROVIDER.putMdc(key, val);
+ }
+
+@@ -37,7 +37,7 @@
+ LoggerProviders.PROVIDER.removeMdc(key);
+ }
+
+- public static Map<String, Object> getMap() {
++ public static Map<String, String> getMap() {
+ return LoggerProviders.PROVIDER.getMdcMap();
+ }
+ }
+--- jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/LoggerProvider.java.orig 2015-05-17 19:06:30.000000000 +0000
++++ jboss-logging-3.1.4.GA/src/main/java/org/jboss/logging/LoggerProvider.java 2015-05-17 21:21:43.083000000 +0000
+@@ -23,13 +23,13 @@
+ public interface LoggerProvider {
+ Logger getLogger(String name);
+
+- Object putMdc(String key, Object value);
++ Object putMdc(String key, String value);
+
+ Object getMdc(String key);
+
+ void removeMdc(String key);
+
+- Map<String, Object> getMdcMap();
++ Map<String, String> getMdcMap();
+
+ void clearNdc();
+
diff --git a/dev-java/jboss-logging/files/jboss-logging-3.1.4-build.xml b/dev-java/jboss-logging/files/jboss-logging-3.1.4-build.xml
new file mode 100644
index 000000000000..35bbf84f9c39
--- /dev/null
+++ b/dev-java/jboss-logging/files/jboss-logging-3.1.4-build.xml
@@ -0,0 +1,202 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/8/14 3:59 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jboss-logging-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jboss-logging-3.1.4.GA"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/jboss/logmanager/jboss-logmanager/1.2.0.GA/jboss-logmanager-1.2.0.GA.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.16/log4j-1.2.16.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <doctitle>&lt;![CDATA[JBoss Logging 3.1.4.GA]]&gt;</doctitle>
+ <header>&lt;![CDATA[JBoss Logging 3.1.4.GA]]&gt;</header>
+ <footer>&lt;![CDATA[JBoss Logging 3.1.4.GA]]&gt;</footer>
+ <bottom>&lt;![CDATA[&lt;i&gt;Copyright &amp;#169; 2012 Red Hat, Inc.&lt;/i&gt;]]&gt;</bottom>
+ <link href="http://java.sun.com/javase/6/docs/api/"/>
+ <doclet name="net.gleamynode.apiviz.APIviz"
+ path="${maven.repo.local}/org/jboss/apiviz/apiviz/1.2.5.GA/apiviz-1.2.5.GA.jar"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="true"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/jboss-logging/jboss-logging-3.1.4.ebuild b/dev-java/jboss-logging/jboss-logging-3.1.4.ebuild
new file mode 100644
index 000000000000..d4c3725843e7
--- /dev/null
+++ b/dev-java/jboss-logging/jboss-logging-3.1.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JBoss logging framework"
+HOMEPAGE="http://www.jboss.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.GA.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="dev-java/jboss-logmanager:0
+ >=dev-java/slf4j-api-1.7.7
+ dev-java/log4j:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${P}.GA/"
+
+EANT_GENTOO_CLASSPATH="jboss-logmanager,slf4j-api,log4j"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ # https://github.com/qos-ch/slf4j/blob/master/slf4j-api/src/main/java/org/slf4j/MDC.java#L226
+ # MDC returns a Map<String, String>
+ # https://github.com/jboss-logging/jboss-logging/blob/master/src/main/java/org/jboss/logging/Slf4jLoggerProvider.java#L57
+ # Yet, for some reason, the JBoss folks have decided that it should return a Map<String, Object> :|
+ # This patch mends this mistake.
+ epatch "${FILESDIR}"/"${P}"-MDC.patch
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-3.1.4.GA.jar
+
+ if use doc; then
+ java-pkg_dojavadoc target/site/apidocs
+ fi
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/jboss-logging/metadata.xml b/dev-java/jboss-logging/metadata.xml
new file mode 100644
index 000000000000..34e7aafc4655
--- /dev/null
+++ b/dev-java/jboss-logging/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jboss-logging/jboss-logging</remote-id>
+ </upstream>
+</pkgmetadata>
+