summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-03-09 21:39:08 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-03-09 22:16:06 +0000
commitebece074ee86c315d4d34da244d3797a3ed8afcf (patch)
tree0ad7236406dc8164921a044f3a27dc25609db03d /dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild
parentwww-client/chromium: Stable channel bump (49.0.2623.87) (diff)
downloadgentoo-ebece074ee86c315d4d34da244d3797a3ed8afcf.tar.gz
gentoo-ebece074ee86c315d4d34da244d3797a3ed8afcf.tar.bz2
gentoo-ebece074ee86c315d4d34da244d3797a3ed8afcf.zip
dev-java/jboss-marshalling: Revision bump with minor improvements
* jboss-modules depends on Java 7 so do the same * DEPEND on app-arch/unzip * Add doc USE flag * Fix JAVA_SRC_DIR * Shorten description Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild')
-rw-r--r--dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..a05530d38dec
--- /dev/null
+++ b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compatible alternative to the JDK serialization API"
+HOMEPAGE="http://jbossmarshalling.jboss.org/"
+SRC_URI="http://download.jboss.org/jbossmarshalling/${P}.CR9-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="dev-java/jboss-modules:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="jboss-modules"