summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-01-21 15:51:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-22 10:02:30 +0100
commit801b4d4c8c7a66459f9cde2c4cd71cff56f470e6 (patch)
treec763dcd844a1e8bd36be5931c6215e43d6af6352 /dev-java/jcifs
parentdev-lang/spidermonkey: update patch set for 91.5.0 (diff)
downloadgentoo-801b4d4c8c7a66459f9cde2c4cd71cff56f470e6.tar.gz
gentoo-801b4d4c8c7a66459f9cde2c4cd71cff56f470e6.tar.bz2
gentoo-801b4d4c8c7a66459f9cde2c4cd71cff56f470e6.zip
dev-java/jcifs: EAPI 8, min java 1.8:*
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jcifs')
-rw-r--r--dev-java/jcifs/jcifs-1.3.19-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/jcifs/jcifs-1.3.19-r1.ebuild b/dev-java/jcifs/jcifs-1.3.19-r1.ebuild
new file mode 100644
index 000000000000..b8169cb79866
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.19-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="https://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="https://jcifs.samba.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+CDEPEND="java-virtuals/servlet-api:3.0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+JAVA_GENTOO_CLASSPATH="servlet-api-3.0"
+
+JAVA_SRC_DIR="src"
+
+DOCS=( README.txt )
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples
+ einstalldocs
+}