summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc-informix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc-informix')
-rw-r--r--dev-java/jdbc-informix/Manifest1
-rw-r--r--dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild60
-rw-r--r--dev-java/jdbc-informix/metadata.xml5
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/jdbc-informix/Manifest b/dev-java/jdbc-informix/Manifest
new file mode 100644
index 000000000000..888a53c56791
--- /dev/null
+++ b/dev-java/jdbc-informix/Manifest
@@ -0,0 +1 @@
+DIST JDBC.3.00.JC3.tar 18447872 RMD160 f38781b5deb7076e854000849e1c1d41231439dc SHA1 856ca3f54433cd3220ce598fde75bbf13cb31839 SHA256 b8a894c0aff02bd690d2082cb4e0e4d2f8e73ff59e3cbdafd28562346902ced7
diff --git a/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
new file mode 100644
index 000000000000..0795867b0f2b
--- /dev/null
+++ b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples"
+
+inherit versionator java-pkg-2
+
+MY_PV="$(replace_version_separator 2 .JC)"
+
+At="JDBC.${MY_PV}.tar"
+DESCRIPTION="JDBC Type 4 Drivers for Informix"
+SRC_URI="${At}"
+HOMEPAGE="http://www.ibm.com/software/data/informix/tools/jdbc/"
+DOWNLOADPAGE="http://www14.software.ibm.com/webapp/download/search.jsp?go=y&rs=ifxjdbc"
+KEYWORDS="amd64 ppc x86"
+LICENSE="informix-jdbc"
+SLOT="0"
+DEPEND=">=virtual/jre-1.4"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+IUSE=""
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Due to licensing restrictions, you need to download the distfile manually."
+ elog "Please navigate to ${DOWNLOADPAGE}"
+ elog "Click on the 'Informix JDBC Driver' link, version ${MY_PV}"
+ elog "Sign up with your IBM account (you need to register)."
+ elog "Go through the license agreement and survey."
+ elog "Download ${At} and place it into ${DISTDIR}"
+ elog "And restart the installation."
+}
+
+src_compile() {
+ einfo "Performing silent installation"
+ addpredict /root/vpd.properties
+ java -jar setup.jar -P product.installLocation=. -silent
+ if use examples; then
+ einfo "Cleaning compiled examples"
+ find demo \( -name \*.so -o -name \*.class -o -name \*.dll \) -delete
+ fi
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ # these are to be copied to app server as servlets
+ insinto /usr/share/${PN}/
+ doins -r proxy
+
+ if use doc; then
+ java-pkg_dojavadoc doc/javadoc
+ dodoc doc/release/jdbc4pg.pdf doc/release/sqlj/ifxsqljug.pdf || die
+ dohtml -r doc/release/* || die
+ fi
+
+ use examples && java-pkg_doexamples demo
+}
diff --git a/dev-java/jdbc-informix/metadata.xml b/dev-java/jdbc-informix/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jdbc-informix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>