summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild')
-rw-r--r--dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild b/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild
new file mode 100644
index 000000000000..e17706848838
--- /dev/null
+++ b/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.5-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source examples test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+At="Jaybird-${PV/_/}-src"
+DESCRIPTION="JDBC Type 2 and 4 drivers for Firebird SQL server"
+HOMEPAGE="http://jaybirdwiki.firebirdsql.org/"
+SRC_URI="mirror://sourceforge/firebird/${At}.zip"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+ dev-java/ant-core
+ dev-java/log4j"
+DEPEND="=virtual/jdk-1.6*
+ app-arch/unzip
+ dev-java/ant-core
+ dev-java/log4j
+ test? (
+ =dev-java/junit-3.8*
+ dev-java/ant-junit
+ )"
+
+S="${WORKDIR}/client-java"
+
+MY_PN="jaybird"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/archive-xml-2.1.0.patch"
+ epatch "${FILESDIR}/compile_xml-2.1.2.patch"
+
+ cd "${S}/lib/"
+ rm -v *.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar
+
+ cd "${S}/src/lib/"
+ # the build.xml unpacks this and uses stuff
+ mv mini-j2ee.jar "${T}" || die "Failed to move mini-j2ee.jar to ${T}"
+ rm -v *.jar *.zip
+ mv "${T}"/mini-j2ee.jar . || die "Failed to move mini-j2ee.jar back from ${T}"
+
+ # Hack to add ant.jar to classpath without patch
+ java-pkg_jar-from ant-core ant.jar jaas.jar
+ java-pkg_jar-from log4j log4j.jar log4j-core.jar
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+ eant $(use test && echo "-Dtests=true") jars \
+ $(use_doc javadocs)
+}
+
+src_install() {
+ cd "${S}/output/lib/"
+ java-pkg_newjar ${MY_PN}-${PV}.jar ${PN}.jar
+
+ for jar in full pool; do
+ java-pkg_newjar ${MY_PN}-${jar}-${PV}.jar ${MY_PN}-${jar}.jar || die "java-pkg_newjar ${MY_PN}-${jar}.jar failed"
+ done
+ if use test; then
+ java-pkg_newjar ${MY_PN}-test-${PV}.jar ${MY_PN}-${jar}.jar || die "java-pkg_newjar ${MY_PN}-${jar}.jar failed"
+ fi
+
+ cd "${S}"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "installing examples failed"
+ fi
+
+ use source && java-pkg_dosrc "${S}"/src/*/org
+
+ cd "${S}/output"
+ use doc && java-pkg_dohtml -r docs/
+ dodoc etc/{*.txt,default.mf}
+ dohtml etc/*.html
+}
+
+src_test() {
+ #
+ # Warning about timeouts without Firebird installed and running Locally
+ #
+ ewarn "You will experience long timeouts when running junit tests"
+ ewarn "without Firebird installed and running locally. The tests will"
+ ewarn "complete without Firebird, but network timeouts prolong the"
+ ewarn "testing phase considerably."
+ ANT_TASKS="ant-junit" eant all-tests-pure-java
+}