summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild')
-rw-r--r--dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild125
1 files changed, 125 insertions, 0 deletions
diff --git a/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild b/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild
new file mode 100644
index 000000000000..ef3a07fbe42b
--- /dev/null
+++ b/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.4.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+IUSE="debug dms doc examples nls ons"
+
+file_main_orig="ojdbc14.jar"
+file_main_dms_orig="ojdbc14dms.jar"
+file_main_debug_orig="ojdbc14_g.jar"
+file_main_dms_debug_orig="ojdbc14dms_g.jar"
+file_doc_orig="javadoc.zip"
+file_demo_orig="demo.tar"
+file_nls_orig="orai18n.jar"
+file_ons_orig="ons.jar"
+
+file_main="${P}-${file_main_orig}"
+file_main_dms="${P}-${file_main_dms_orig}"
+file_main_debug="${P}-${file_main_debug_orig}"
+file_main_dms_debug="${P}-${file_main_dms_debug_orig}"
+file_doc="${PN}-10.2.0.1-${file_doc_orig}"
+file_demo="${P}-${file_demo_orig}"
+file_nls="${P}-${file_nls_orig}"
+file_ons="${PN}-10.2.0.3-${file_ons_orig}"
+
+DESCRIPTION="JDBC 3.0 Drivers for Oracle"
+HOMEPAGE="http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html"
+DOWNLOAD_PAGE="http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-10201-088211.html"
+SRC_URI="
+ !dms? (
+ !debug? ( ${file_main} )
+ debug? ( ${file_main_debug} )
+ )
+ dms? (
+ !debug? ( ${file_main_dms} )
+ debug? ( ${file_main_dms_debug} )
+ )
+ doc? ( ${file_doc} )
+ examples? ( ${file_demo} )
+ nls? ( ${file_nls} )
+ ons? ( ${file_ons} )"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="oracle-jdbc"
+SLOT="10.2"
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+determine_files() {
+ if use dms; then
+ if use debug; then
+ file_main_used=${file_main_dms_debug}
+ file_main_used_orig=${file_main_dms_debug_orig}
+ else
+ file_main_used=${file_main_dms}
+ file_main_used_orig=${file_main_dms_orig}
+ fi
+ else
+ if use debug; then
+ file_main_used=${file_main_debug}
+ file_main_used_orig=${file_main_debug_orig}
+ else
+ file_main_used=${file_main}
+ file_main_used_orig=${file_main_orig}
+ fi
+ fi
+}
+
+pkg_nofetch() {
+ determine_files
+ einfo
+ einfo " Because of license terms and file name conventions, please:"
+ einfo
+ einfo " 1. Visit ${DOWNLOAD_PAGE}"
+ einfo " (you may need to create an account on Oracle's site)"
+ einfo " 2. Download the appropriate files:"
+ einfo " - ${file_main_used_orig}"
+ use doc && einfo " - ${file_doc_orig}"
+ use examples && einfo " - ${file_demo_orig}"
+ use nls && einfo " - ${file_nls_orig}"
+ use ons && einfo " - ${file_ons_orig}"
+ einfo " 3. Rename the files:"
+ einfo " - ${file_main_used_orig} --> ${file_main_used}"
+ use doc && einfo " - ${file_doc_orig} --> ${file_doc}"
+ use examples && einfo " - ${file_demo_orig} --> ${file_demo}"
+ use nls && einfo " - ${file_nls_orig} --> ${file_nls}"
+ use ons && einfo " - ${file_ons_orig} --> ${file_ons}"
+ einfo " 4. Place the files in ${DISTDIR}"
+ einfo " 5. Resume the installation."
+ einfo
+}
+
+src_unpack() {
+ determine_files
+ cp "${DISTDIR}/${file_main_used}" ${PN}.jar || die
+
+ if use nls; then
+ cp "${DISTDIR}/${file_nls}" ${file_nls_orig} || die
+ fi
+
+ if use ons; then
+ cp "${DISTDIR}/${file_ons}" ${file_ons_orig} || die
+ fi
+
+ if use doc; then
+ mkdir "${S}/javadoc" && cd "${S}/javadoc"
+ unpack ${file_doc}
+ fi
+
+ if use examples; then
+ cd "${S}"
+ unpack ${file_demo}
+ mv Samples-Readme.txt samples/ || die
+ fi
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+
+ use doc && java-pkg_dojavadoc javadoc
+ use examples && java-pkg_doexamples samples
+}