summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jebl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jebl')
-rw-r--r--dev-java/jebl/Manifest1
-rw-r--r--dev-java/jebl/jebl-2013.02.18.ebuild41
-rw-r--r--dev-java/jebl/jebl-9999.ebuild43
-rw-r--r--dev-java/jebl/metadata.xml5
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-java/jebl/Manifest b/dev-java/jebl/Manifest
new file mode 100644
index 000000000000..a7efae69bc1e
--- /dev/null
+++ b/dev-java/jebl/Manifest
@@ -0,0 +1 @@
+DIST jebl-2013.02.18.tar.xz 306444 SHA256 b20a815980241b8e9c113f1b0fd08361f1bfb10b69ae3f471c8a8c62bed4060f SHA512 2f18ebbe30efbaab879a290a771a6e3d8fd1ba8afb6b8e0b3e9fb36252a4f65adf0929b77ef6922def61f9430ffcfc8486d822cd463f7ca6752418139d41aafb WHIRLPOOL b7687fc6a1975298e73d9bfc353a51a9197de514a72f72797ee8bf5c7926b28791acd790847414101d7bc0fc369cedb723f8f30e9485d3e90bd6a87ed8bcb088
diff --git a/dev-java/jebl/jebl-2013.02.18.ebuild b/dev-java/jebl/jebl-2013.02.18.ebuild
new file mode 100644
index 000000000000..ec0d291ab926
--- /dev/null
+++ b/dev-java/jebl/jebl-2013.02.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/trunk/jebl"
+#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/tags/${P//./_}"
+
+JAVA_PKG_IUSE="doc"
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="document"
+
+#inherit subversion java-pkg-2 java-ant-2
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Evolutionary Biology Library"
+HOMEPAGE="http://jebl.sourceforge.net/"
+#SRC_URI=""
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+CDEPEND=""
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+java_prepare() {
+ rm -rf "${S}/src/org/virion/jam/maconly" || die
+}
+
+src_install() {
+ java-pkg_dojar dist/jebl.jar || die
+ java-pkg_dojar dist/jam.jar || die
+ use doc && java-pkg_dojavadoc doc/api
+}
diff --git a/dev-java/jebl/jebl-9999.ebuild b/dev-java/jebl/jebl-9999.ebuild
new file mode 100644
index 000000000000..32115c9f4878
--- /dev/null
+++ b/dev-java/jebl/jebl-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/trunk/jebl"
+#ESVN_REPO_URI="https://jebl.svn.sourceforge.net/svnroot/jebl/tags/${P//./_}"
+
+JAVA_PKG_IUSE="doc"
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="document"
+
+inherit subversion java-pkg-2 java-ant-2
+#inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Evolutionary Biology Library"
+HOMEPAGE="http://jebl.sourceforge.net/"
+SRC_URI=""
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+KEYWORDS=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+CDEPEND=""
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P//./_}"
+
+java_prepare() {
+ rm -rf "${S}/src/org/virion/jam/maconly" || die
+}
+
+src_install() {
+ java-pkg_dojar dist/jebl.jar || die
+ java-pkg_dojar dist/jam.jar || die
+ use doc && java-pkg_dojavadoc doc/api
+}
diff --git a/dev-java/jebl/metadata.xml b/dev-java/jebl/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jebl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>