summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-05 19:10:34 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-05 19:48:21 +0000
commitb38360ca60ee6c12f505cc62da14422ef6b69638 (patch)
treee01e927a195b14620c0d21d1f2b4947f989406a6 /dev-java/jffi/jffi-1.0.11-r1.ebuild
parentdev-util/unifdef: Bump to version 2.11 (diff)
downloadgentoo-b38360ca60ee6c12f505cc62da14422ef6b69638.tar.gz
gentoo-b38360ca60ee6c12f505cc62da14422ef6b69638.tar.bz2
gentoo-b38360ca60ee6c12f505cc62da14422ef6b69638.zip
dev-java/jffi: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/jffi/jffi-1.0.11-r1.ebuild')
-rw-r--r--dev-java/jffi/jffi-1.0.11-r1.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/dev-java/jffi/jffi-1.0.11-r1.ebuild b/dev-java/jffi/jffi-1.0.11-r1.ebuild
index 7af0347c5f3e..271b085e8bd6 100644
--- a/dev-java/jffi/jffi-1.0.11-r1.ebuild
+++ b/dev-java/jffi/jffi-1.0.11-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-
JAVA_PKG_IUSE="doc source test"
inherit eutils java-pkg-2 java-ant-2 versionator
@@ -14,32 +13,42 @@ SRC_URI="https://github.com/jnr/jffi/tarball/${PV} -> ${P}.tar.gz"
LICENSE="|| ( Apache-2.0 LGPL-3 )"
SLOT="1.0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ppc x86"
IUSE=""
-COMMON_DEP="
+CDEPEND="
virtual/libffi"
-RDEPEND="${COMMON_DEP}
- >=virtual/jre-1.5"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.5
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
virtual/pkgconfig
test? (
dev-java/ant-junit:0
dev-java/junit:4
)"
+PATCHES=(
+ "${FILESDIR}"/${P}_no-werror.patch
+)
+
src_unpack() {
unpack ${A}
mv jnr-jffi-* "${P}" || die
}
java_prepare() {
+ java-pkg_clean
+
cp "${FILESDIR}"/${PN}_maven-build.xml build.xml || die
- epatch "${FILESDIR}"/${P}_no-werror.patch
- sed -i -e 's/-Werror //' libtest/GNUmakefile || die
- find "${WORKDIR}" -iname '*.jar' -delete || die
+ epatch "${PATCHES[@]}"
+
+ sed -i -e 's/-Werror //' libtest/GNUmakefile || die
# Fix build with GCC 4.7 #421501
sed -i -e "s|-mimpure-text||g" jni/GNUmakefile libtest/GNUmakefile || die