summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-11-02 23:24:17 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-11-02 23:40:57 +0000
commit35c081c398a95b522be2ae83ce52616fa6517aed (patch)
treec6b6aa30b83d62a33f3324e0017e6889a9b33939 /dev-java/jflex/jflex-1.6.1.ebuild
parentdev-lang/php: revbump php-5.6.15 to fix a segfault. (diff)
downloadgentoo-35c081c398a95b522be2ae83ce52616fa6517aed.tar.gz
gentoo-35c081c398a95b522be2ae83ce52616fa6517aed.tar.bz2
gentoo-35c081c398a95b522be2ae83ce52616fa6517aed.zip
dev-java/jflex: Rewrite for version bump to 1.6.1
Rewritten using java-pkg-simple to give us more control over this tricky package. javacup has become a PDEPEND, meaning that the bundled version is automatically used on the first build instead of it having a system-jflex USE flag. ~arm keyword added with workarounds for different problems encountered with both IcedTea and Oracle. ~ppc64 keyword temporarily dropped until it gets Java 7, which the newer javacup requires. Please stabilise this at the same time as dev-java/qdox-1.12.1-r1. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-java/jflex/jflex-1.6.1.ebuild')
-rw-r--r--dev-java/jflex/jflex-1.6.1.ebuild121
1 files changed, 121 insertions, 0 deletions
diff --git a/dev-java/jflex/jflex-1.6.1.ebuild b/dev-java/jflex/jflex-1.6.1.ebuild
new file mode 100644
index 000000000000..50f314d50813
--- /dev/null
+++ b/dev-java/jflex/jflex-1.6.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JFlex is a lexical analyzer generator for Java"
+HOMEPAGE="http://www.jflex.de/"
+SRC_URI="http://${PN}.de/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples test vim-syntax"
+
+CDEPEND="dev-java/ant-core:0"
+
+RDEPEND=">=virtual/jre-1.6
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )
+ ${CDEPEND}"
+
+PDEPEND=">=dev-java/javacup-0.11b_p20151001:0"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # See below for details.
+ epatch "${FILESDIR}/icedtea-arm.patch"
+
+ # We need the bundled jflex.jar.
+ rm -rv ${JAVA_SRC_DIR}/java_cup examples/pom.xml || die
+
+ # Remove the bundled java-cup.jar if unneeded.
+ if has_version ${PDEPEND}; then
+ rm -v lib/java-cup-*.jar || die
+ fi
+}
+
+src_configure() {
+ # javacup is a cyclic dependency. Use the package if we have it,
+ # otherwise use the bundled version and install the package later.
+ if has_version ${PDEPEND}; then
+ # Use PORTAGE_QUIET to suppress a QA warning that is spurious
+ # thanks to has_version above. This is Portage-specific but
+ # showing the warning elsewhere isn't the end of the world.
+ JAVACUP=$(PORTAGE_QUIET=1 java-pkg_getjar --build-only javacup javacup.jar)
+ else
+ JAVACUP=$(echo lib/java-cup-*.jar)
+ fi
+
+ JAVA_GENTOO_CLASSPATH_EXTRA="$(java-pkg_getjars --build-only ant-core):${JAVACUP}"
+}
+
+jflex_compile() {
+ java "${@}" jflex.Main -d ${JAVA_SRC_DIR}/${PN} --skel src/main/${PN}/skeleton.nested src/main/${PN}/LexScan.flex || die
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_compile() {
+ java -jar "${JAVACUP}" -destdir ${JAVA_SRC_DIR}/${PN} -package ${PN} -parser LexParse -interface src/main/cup/LexParse.cup || die
+
+ # The IcedTea ARM HotSpot port (as of 2.6.1) hangs when running
+ # jflex. We have patched jflex to fix it but we have to run the
+ # bundled version first. -Xint works around the problem. See
+ # http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2678.
+ use arm && local JFLEX_ARGS="-Xint"
+
+ # First compile (without doc/source) using the bundled jflex.
+ JAVA_PKG_IUSE= jflex_compile -cp "lib/${P}.jar:${JAVACUP}" ${JFLEX_ARGS}
+
+ # Then recompile using the fresh jflex.
+ jflex_compile -cp "${PN}.jar:${JAVACUP}"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${PN} --main ${PN}.Main
+
+ java-pkg_register-dependency javacup javacup-runtime.jar
+ java-pkg_register-ant-task
+
+ use examples && java-pkg_doexamples examples
+ dodoc {changelog,README}.md
+
+ if use doc; then
+ dodoc doc/*.pdf
+ docinto html
+ dodoc doc/*.{css,html,png} doc/COPYRIGHT
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins lib/${PN}.vim
+ fi
+}
+
+src_test() {
+ if use arm && java-pkg_current-vm-matches oracle-jdk-bin-1.8; then
+ # This results in a StackOverflowError as of 1.8.0.65 but works
+ # fine on icedtea:7. Don't know about icedtea:8 yet.
+ rm -v src/test/java/jflex/EmitterTest.java || die
+ fi
+
+ local CP="src/test/java:${PN}.jar:${JAVA_GENTOO_CLASSPATH_EXTRA}:$(java-pkg_getjars junit-4)"
+
+ local TESTS=$(find src/test/java -name "*Test*.java" -printf "%P\n")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -classpath "${CP}" $(find src/test/java -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}