summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jfreesvg/jfreesvg-3.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jfreesvg/jfreesvg-3.0.ebuild')
-rw-r--r--dev-java/jfreesvg/jfreesvg-3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/jfreesvg/jfreesvg-3.0.ebuild b/dev-java/jfreesvg/jfreesvg-3.0.ebuild
new file mode 100644
index 000000000000..527cda860757
--- /dev/null
+++ b/dev-java/jfreesvg/jfreesvg-3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JFreeSVG is a fast, light-weight, vector graphics library for the Java platform"
+HOMEPAGE="http://www.jfree.org/jfreesvg/"
+SRC_URI="mirror://sourceforge/jfreegraphics2d/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.jar' -print -delete || die
+}
+
+src_compile() {
+ if ! use debug; then
+ antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+ fi
+ eant -f ant/build.xml compile $(use_doc) $antflags
+}
+
+src_install() {
+ java-pkg_newjar "./lib/${P}.jar" ${PN}.jar
+ dodoc README.md
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/main/java
+}