summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-07 14:26:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-07 18:18:42 +0200
commitff765ab963ec5189e9a8993f166c1141d014f4f5 (patch)
treebe149565bb82975a9f033a5d730142c5d5a60644 /dev-java/jibx
parentdev-php/pecl-dbase: New package wrt bug 418353 (diff)
downloadgentoo-ff765ab963ec5189e9a8993f166c1141d014f4f5.tar.gz
gentoo-ff765ab963ec5189e9a8993f166c1141d014f4f5.tar.bz2
gentoo-ff765ab963ec5189e9a8993f166c1141d014f4f5.zip
dev-java/jibx: add a SLOT to jibx-1.2.
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --force
Diffstat (limited to 'dev-java/jibx')
-rw-r--r--dev-java/jibx/jibx-1.2.6-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/jibx/jibx-1.2.6-r1.ebuild b/dev-java/jibx/jibx-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..3a2db81cf37a
--- /dev/null
+++ b/dev-java/jibx/jibx-1.2.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bind XML to Java code"
+HOMEPAGE="http://jibx.sourceforge.net/"
+SRC_URI="
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-extras/${PV}/${PN}-extras-${PV}-sources.jar
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-bind/${PV}/${PN}-bind-${PV}-sources.jar
+ https://repo1.maven.org/maven2/org/${PN}/${PN}-run/${PV}/${PN}-run-${PV}-sources.jar
+"
+
+LICENSE="BSD"
+SLOT="1.2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+CDEPEND="
+ dev-java/bcel:0
+ dev-java/xpp3:0
+ dev-java/jdom:0
+ dev-java/dom4j:1
+ dev-java/log4j:0
+ dev-java/joda-time:0
+ dev-java/ant-core:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="
+ joda-time
+ ant-core
+ dom4j-1
+ log4j
+ jdom
+ bcel
+ xpp3
+"