summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/joda-time/joda-time-2.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/joda-time/joda-time-2.7.ebuild')
-rw-r--r--dev-java/joda-time/joda-time-2.7.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/joda-time/joda-time-2.7.ebuild b/dev-java/joda-time/joda-time-2.7.ebuild
new file mode 100644
index 000000000000..4c63fd7c7b2e
--- /dev/null
+++ b/dev-java/joda-time/joda-time-2.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc examples source test"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes"
+HOMEPAGE="http://www.joda.org/joda-time/ https://github.com/JodaOrg/joda-time/"
+SRC_URI="https://github.com/JodaOrg/${PN}/releases/download/v${PV}/${P}-dist.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/joda-convert:0
+ test? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )"
+RDEPEND=">=virtual/jre-1.5"
+
+java_prepare() {
+ rm -v *.jar || die "Failed to remove bundled jars."
+ cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die "Failed to copy build file."
+
+ mkdir -p "${S}"/target/classes || die "Failed to create target classes directory."
+ cp -Rv "${S}"/src/tz-data/* "${S}"/target/classes/ || die "Failed to copy timezone data."
+
+ mkdir -p "${S}"/target/classes/org/joda/time/format || die "Failed to create target classes subdirectory."
+ cp -Rv "${S}"/src/main/java/org/joda/time/format/*properties "${S}"/target/classes/org/joda/time/format/ || die "Failed to copy message bundles."
+}
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar):$(java-pkg_getjar --build-only junit junit.jar)"
+
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/main/java/*
+}