summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-04-21 18:03:43 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-21 19:31:44 +0200
commitfb46ad9cf448a4e33e8f0e067ae5553fb3dbfd55 (patch)
treea3d767d8efb2087aee7619792f53e19b0972c8d2 /dev-java/joni
parentdev-java/avalon-framework: remove unused slot (diff)
downloadgentoo-fb46ad9cf448a4e33e8f0e067ae5553fb3dbfd55.tar.gz
gentoo-fb46ad9cf448a4e33e8f0e067ae5553fb3dbfd55.tar.bz2
gentoo-fb46ad9cf448a4e33e8f0e067ae5553fb3dbfd55.zip
dev-java/joni: EAPI 7, min java 1.8
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/20489/commits/af8b5aa4e4150a1d5c3ebfc4f7f073918ee21f3e Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/joni')
-rw-r--r--dev-java/joni/joni-2.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/joni/joni-2.1.0-r1.ebuild b/dev-java/joni/joni-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..cf7f00117692
--- /dev/null
+++ b/dev-java/joni/joni-2.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+CDEPEND="dev-java/asm:9
+ dev-java/jcodings:1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-9 jcodings-1"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}