summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jstun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jstun')
-rw-r--r--dev-java/jstun/Manifest1
-rw-r--r--dev-java/jstun/jstun-0.7.3.ebuild62
-rw-r--r--dev-java/jstun/metadata.xml5
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-java/jstun/Manifest b/dev-java/jstun/Manifest
new file mode 100644
index 000000000000..13ea15193eaa
--- /dev/null
+++ b/dev-java/jstun/Manifest
@@ -0,0 +1 @@
+DIST jstun-0.7.3.src.tar.gz 173666 SHA256 dba79de7a92ab7f9c9e67e995999db99df75149369eff3571779702351f7509b SHA512 03dd54331c79992ef2c387eb78fde8c98b58e3818515bf57beafb6157914fe9295d3ff043ac8aab78490ac2582969c07e1891ddbefaa702c3816ddac061ceb18 WHIRLPOOL b7d7553b17e656b537b701615d9774b0b814711ee41d100128bcbec30d939962fd8d397fae6cbd0e923f0e45541685f44473aaa8a2edc0751d7a51144fa45202
diff --git a/dev-java/jstun/jstun-0.7.3.ebuild b/dev-java/jstun/jstun-0.7.3.ebuild
new file mode 100644
index 000000000000..cda937c9cff1
--- /dev/null
+++ b/dev-java/jstun/jstun-0.7.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java-based STUN implementation"
+HOMEPAGE="http://jstun.javawi.de/"
+SRC_URI="http://${PN}.javawi.de/${P}.src.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEP="dev-java/slf4j-api:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/STUN"
+
+# Tests contain no main function; demos contain main function, but contact
+# external domains as well as aren't really tests. TODO: A main function needs
+# to be written in order to be able to test de.javawi.jstun.AllTests.
+RESTRICT="test"
+
+EANT_BUILD_XML="build/build.xml"
+
+java_prepare() {
+ rm -v *.jar || die
+ rm -v build/*.jar || die
+
+ java-pkg_jar-from slf4j-api
+}
+
+EANT_TEST_GENTOO_CLASSPATH="junit"
+EANT_TEST_TARGET="jar-test"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_test() {
+ local cp="$(java-pkg_getjars --build-only junit)"
+
+ java-pkg-2_src_test
+
+ java -cp target/${PN}-test-${PV}.jar:${cp} de.javawi.jstun.AllTests \
+ || die "Tests failed."
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/javadoc
+ use source && java-pkg_dosrc src
+}
diff --git a/dev-java/jstun/metadata.xml b/dev-java/jstun/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jstun/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>