summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-05-01 23:32:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-05-01 23:33:03 +0100
commit2310234c34897cb1160ef8227e19f0b4a778a85e (patch)
treed9e77c5bc4d3bf6ad6dfd87d1a46fb7a1a0b3044 /dev-java/jts-core/jts-core-1.14.ebuild
parentnet-mail/notmuch: Bump version (diff)
downloadgentoo-2310234c34897cb1160ef8227e19f0b4a778a85e.tar.gz
gentoo-2310234c34897cb1160ef8227e19f0b4a778a85e.tar.bz2
gentoo-2310234c34897cb1160ef8227e19f0b4a778a85e.zip
dev-java/jts-core: New package, required by h2
h2 is currently in java-overlay. Apparently several other things require this too. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/jts-core/jts-core-1.14.ebuild')
-rw-r--r--dev-java/jts-core/jts-core-1.14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/jts-core/jts-core-1.14.ebuild b/dev-java/jts-core/jts-core-1.14.ebuild
new file mode 100644
index 000000000000..15df7fa5a2cb
--- /dev/null
+++ b/dev-java/jts-core/jts-core-1.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# The project recently switched to git. There are no tags yet.
+GIT_REF="f67d35c1da06922c8165f66a919490ee94a04649"
+
+MY_PN="jts"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JTS Topology Suite for Java"
+HOMEPAGE="http://tsusiatsoftware.net/jts/main.html"
+SRC_URI="https://github.com/dr-jts/jts/archive/${GIT_REF}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${MY_PN}-${GIT_REF}/${MY_PN}"
+JAVA_SRC_DIR="java/src"
+
+java_prepare() {
+ java-pkg_clean
+
+ # Use text-based test runner.
+ sed -i "s/swingui/textui/g" java/test/test/jts/junit/SimpleTest.java || die
+}
+
+src_test() {
+ cd java/test || die
+ local CP=".:${S}/${PN}.jar:$(java-pkg_getjars junit-4)"
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" test.jts.junit.MasterTester
+}