summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-04-06 20:49:38 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-04-11 08:46:33 +0200
commitf8afef90bfbda000a0be3fcc3db25adf128cec42 (patch)
treec223293c9d38d443f53c5ae6e668d5e6b7711f53 /dev-java/junit
parentdev-java/junit: add 4.13.2_p20240222 to allow jdk:21 (diff)
downloadgentoo-f8afef90bfbda000a0be3fcc3db25adf128cec42.tar.gz
gentoo-f8afef90bfbda000a0be3fcc3db25adf128cec42.tar.bz2
gentoo-f8afef90bfbda000a0be3fcc3db25adf128cec42.zip
dev-java/junit: update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/junit-3.8.2-r2.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-java/junit/junit-3.8.2-r2.ebuild b/dev-java/junit/junit-3.8.2-r2.ebuild
index 2872a332ce63..0fdc555922d9 100644
--- a/dev-java/junit/junit-3.8.2-r2.ebuild
+++ b/dev-java/junit/junit-3.8.2-r2.ebuild
@@ -1,31 +1,30 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source"
MAVEN_ID="junit:junit:3.8.2"
inherit java-pkg-2 java-pkg-simple
-MY_P=${P/-/}
-
DESCRIPTION="Simple framework to write repeatable tests"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-HOMEPAGE="http://www.junit.org/"
+SRC_URI="mirror://sourceforge/project/junit/junit/${PV}/junit${PV}.zip"
+HOMEPAGE="https://junit.org/"
+S="${WORKDIR}/junit${PV}"
+
LICENSE="CPL-1.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+BDEPEND="app-arch/unzip"
DEPEND=">=virtual/jdk-1.8"
RDEPEND=">=virtual/jre-1.8"
-DOCS=( README.html cpl-v10.html )
+HTML_DOCS=( README.html cpl-v10.html )
JAVA_SRC_DIR="${PN}"
-S="${WORKDIR}/${MY_P}"
-
src_unpack() {
unpack ${A}
cd "${S}" || die
@@ -33,11 +32,6 @@ src_unpack() {
}
src_prepare() {
- default
+ java-pkg-2_src_prepare
java-pkg_clean
}
-
-src_install() {
- java-pkg-simple_src_install
- einstalldocs
-}