summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jvyaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jvyaml')
-rw-r--r--dev-java/jvyaml/Manifest1
-rw-r--r--dev-java/jvyaml/files/jvyaml-0.2-tests.patch20
-rw-r--r--dev-java/jvyaml/files/jvyaml-0.2.1-tests.patch34
-rw-r--r--dev-java/jvyaml/jvyaml-0.2.1-r1.ebuild47
-rw-r--r--dev-java/jvyaml/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-java/jvyaml/Manifest b/dev-java/jvyaml/Manifest
new file mode 100644
index 000000000000..2874ef42f511
--- /dev/null
+++ b/dev-java/jvyaml/Manifest
@@ -0,0 +1 @@
+DIST jvyaml-src-0.2.1.tar.gz 202550 SHA256 a21c47679bac174b6185265358c7c8e151ac1ee8c4f9fbceebe9b15a37a10382 SHA512 edac9309c285cf569c453cd63f2cbd5e0a29012936af181616010bebb4eac2c474e2b37463af61b5e66876ffba517040796c596ac2bbcc9dad2af7aedf324221 WHIRLPOOL a30e39f862ed5eefabcb79820f190bffeccffda79ceae1864cb3364fbda1588eb345e7b1fe1264cfd84710e56aadc36e9c816e6371a46e7c1f0225e726065304
diff --git a/dev-java/jvyaml/files/jvyaml-0.2-tests.patch b/dev-java/jvyaml/files/jvyaml-0.2-tests.patch
new file mode 100644
index 000000000000..0f6997ebbc40
--- /dev/null
+++ b/dev-java/jvyaml/files/jvyaml-0.2-tests.patch
@@ -0,0 +1,20 @@
+--- build.xml 2007-01-05 21:30:59.000000000 +0100
++++ build.xml 2007-01-05 21:31:46.000000000 +0100
+@@ -47,7 +47,7 @@
+ </target>
+
+ <target name="test" depends="compile-tests" description="Runs all tests">
+- <junit haltonfailure="false">
++ <junit haltonfailure="true">
+ <classpath>
+ <pathelement location="${build.dir}/classes/jvyaml"/>
+ <pathelement location="${build.dir}/test"/>
+@@ -61,7 +61,7 @@
+ </junit>
+ </target>
+
+- <target name="jar" depends="test" description="Create the jvyaml.jar file">
++ <target name="jar" depends="compile" description="Create the jvyaml.jar file">
+ <jar destfile="${lib.dir}/jvyaml.jar">
+ <fileset dir="${jvyaml.classes.dir}">
+ <include name="**/*.class"/>
diff --git a/dev-java/jvyaml/files/jvyaml-0.2.1-tests.patch b/dev-java/jvyaml/files/jvyaml-0.2.1-tests.patch
new file mode 100644
index 000000000000..5dac1832afee
--- /dev/null
+++ b/dev-java/jvyaml/files/jvyaml-0.2.1-tests.patch
@@ -0,0 +1,34 @@
+Only in jvyaml-0.2.1-patched/: build
+Files jvyaml-0.2.1/lib/jvyaml.jar and jvyaml-0.2.1-patched/lib/jvyaml.jar differ
+diff -ru jvyaml-0.2.1/src/test/org/jvyaml/YAMLDumpTest.java jvyaml-0.2.1-patched/src/test/org/jvyaml/YAMLDumpTest.java
+--- jvyaml-0.2.1/src/test/org/jvyaml/YAMLDumpTest.java 2006-09-24 13:07:19.000000000 -0400
++++ jvyaml-0.2.1-patched/src/test/org/jvyaml/YAMLDumpTest.java 2007-03-08 00:39:04.000000000 -0500
+@@ -28,6 +28,8 @@
+ import java.util.List;
+ import java.util.HashMap;
+ import java.util.ArrayList;
++import java.util.TimeZone;
++import java.text.DecimalFormat;
+
+ import junit.framework.TestCase;
+
+@@ -71,9 +73,18 @@
+ final java.util.Calendar cal = java.util.Calendar.getInstance();
+ cal.clear();
+ cal.set(1982,5-1,3); // Java's months are zero-based...
++
++ // Nasty hack to figure out timezone so we can figure out what to
++ // expect when we do YAML#dump
++ TimeZone tz = cal.getTimeZone();
++ int offset = tz.getOffset(cal.getTimeInMillis()) / 3600000;
++ DecimalFormat format = new DecimalFormat("00");
++ String offsetString = format.format(offset);
++ offsetString = ( offset >= 0 ? "+" : "") + offsetString;
+
+ final TestBean toDump = new TestBean("Ola Bini", 24, cal.getTime());
+- assertEquals("--- !java/object:org.jvyaml.TestBean\nname: Ola Bini\nage: 24\nborn: 1982-05-03 00:00:00 +02:00\n", YAML.dump(toDump));
++// assertEquals("--- !java/object:org.jvyaml.TestBean\nname: Ola Bini\nage: 24\nborn: 1982-05-03 00:00:00 +02:00\n", YAML.dump(toDump));
++ assertEquals("--- !java/object:org.jvyaml.TestBean\nname: Ola Bini\nage: 24\nborn: 1982-05-03 00:00:00 " + offsetString + ":00\n", YAML.dump(toDump));
+
+ }
+ }// YAMLDumpTest
diff --git a/dev-java/jvyaml/jvyaml-0.2.1-r1.ebuild b/dev-java/jvyaml/jvyaml-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..c1065f4b5b6f
--- /dev/null
+++ b/dev-java/jvyaml/jvyaml-0.2.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Java YAML parser and emitter"
+HOMEPAGE="https://jvyaml.dev.java.net/"
+SRC_URI="https://${PN}.dev.java.net/files/documents/5215/41455/${PN}-src-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? (
+ dev-java/ant-junit
+ =dev-java/junit-3*
+ )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # https://jvyaml.dev.java.net/issues/show_bug.cgi?id=6
+ epatch "${FILESDIR}/${PN}-0.2-tests.patch"
+
+ # https://jvyaml.dev.java.net/issues/show_bug.cgi?id=5
+ epatch "${FILESDIR}/${P}-tests.patch"
+
+ cd lib
+ rm -v *.jar || die
+ use test && java-pkg_jar-from --build-only junit
+}
+
+#no javadoc target
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ dodoc README CREDITS || die
+ use source && java-pkg_dosrc src/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
diff --git a/dev-java/jvyaml/metadata.xml b/dev-java/jvyaml/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/jvyaml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>