summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/lucene/lucene-2.2.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/lucene/lucene-2.2.0.ebuild')
-rw-r--r--dev-java/lucene/lucene-2.2.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/lucene/lucene-2.2.0.ebuild b/dev-java/lucene/lucene-2.2.0.ebuild
new file mode 100644
index 000000000000..b6c685e1b7d9
--- /dev/null
+++ b/dev-java/lucene/lucene-2.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_PKG_BSFIX_ALL="no"
+JAVA_PKG_BSFIX_NAME="build.xml common-build.xml"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="High-performance, full-featured text search engine written entirely in Java"
+HOMEPAGE="http://lucene.apache.org"
+SRC_URI="mirror://apache/lucene/java/archive/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-nodeps
+ dev-java/javacc
+ test? ( dev-java/ant-junit =dev-java/junit-3* )"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # regenerate javacc files just because we can
+ # put javacc.jar on ant's classpath here even when <javacc> task
+ # doesn't use it - it's to fool the <available> test, first time
+ # it's useful not to have ignoresystemclasses=true...
+ ANT_TASKS="ant-nodeps javacc" eant \
+ -Djavacc.home="${EPREFIX}"/usr/share/javacc/lib javacc
+ ANT_TASKS="none" eant -Dversion=${PV} jar-core jar-demo $(use_doc javadocs)
+}
+
+src_test() {
+ java-ant_rewrite-classpath common-build.xml
+ EANT_GENTOO_CLASSPATH="junit ant-core" ANT_TASKS="ant-junit" eant test-core
+}
+
+src_install() {
+ dodoc CHANGES.txt README.txt
+ java-pkg_newjar build/${PN}-core-${PV}.jar ${PN}-core.jar
+ java-pkg_newjar build/${PN}-demos-${PV}.jar ${PN}-demos.jar
+
+ if use doc; then
+ dohtml -r docs/*
+ java-pkg_dojavadoc build/docs/api
+ fi
+ use source && java-pkg_dosrc src/java/org
+}